Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.53 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 12 replies, has 3 voices.

Last updated by Dražen Duvnjak 1 month ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
April 21, 2021 at 4:20 am #8586573

jeffreyV-9

Any news on this? Our site dashboard is unusable with this bug. We have spent thousands of dollars on translation services already but can't push anything live until resolved.

April 21, 2021 at 4:20 am #8586575

Riffaz

Please check the reply here: https://wpml.org/forums/topic/my-site-dashboard-is-extremely-slow-with-wpml-enabled/page/2/#post-8478981
and continue in this ticket.

April 21, 2021 at 5:33 am #8587141

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

in the last ticket we were waiting for feedback from you. Since the last one was closed let's continue with this new one.

-

I have checked with our developers and it seems the workaround we shared with you before, should help you out. The only problem that is still causing slowness is visiting the Translation Jobs page.

You showed us very clearly in your video: https://wpml.org/forums/topic/my-site-dashboard-is-extremely-slow-with-wpml-enabled/page/2/#post-8221693

Can you please share again a new video, showing us what happens and what seems to be the problem for you stopping and affecting your work. Not sure we completely understand your situation here.

We are aware of 2 slow queries, for 1st there was a quick fix provided, and for the second that happens when visiting the Translation job, I think there is no quick fix for now. Everything else on your website should be working fine.

Please let us know.

Thanks,
Drazen

April 26, 2021 at 11:52 pm #8629613

jeffreyV-9

Slowness is not only when visiting the translation manager page. It also slows down logging-in to wp-admin, which makes working on the site very frustrating. Specially for us because we have several agents that work directly in our site every day.

In order to reproduce the issue, you can create a simple script using WP-CLI that adds at least 300,000 dummy WordPress users, then you'll notice the issue.

I remember you were able to reproduce the issue with a copy of our data. Did you try the quick fix yourself? because it did not help for us: both (translation manager page and logging-in to wp dashboard) are slow even with the proposed quick fix.

I'm recording a new video today after fixing other issues I have in the staging site I have WPML installed.

April 27, 2021 at 12:27 am #8629625

jeffreyV-9

Heres a video showing the issue. There, you can see that logging-in takes a lot of time. Then, I try to use Query monitor to see the slow query that's causing this but could not find it, probably because it's a redirect after the login. Lastly, you can see how disabling the translation manager plugin makes the login fast again.

hidden link

April 27, 2021 at 7:00 am #8630907

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thank you very much for the informative reply and for sharing a video.

I have forward everything to our developer working on this case and will update you soon.

Thanks for the patience,
Drazen

April 28, 2021 at 11:23 am #8643939

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

we have checked your site and noticed you are using an older version of WPML.

I have just updated it to the latest and checked login to the site, and it seems to work fine, a bit slower but that is excepted since you have a lot of users, but a lot faster than what you experience before and showed us in video.

It seems to me it is fine, please check the video: hidden link

Can you please check and let me know if you still experience issues?

Thanks,
Drazen

April 28, 2021 at 4:00 pm #8646267

jeffreyV-9

We have people logged in and working on site today, so I disabled the translation manager plugin so they can work. I noticed that at some point the plugin was enabled again and site went slow again so I disabled and deleted it. I thought that the plugin was being automatically enabled by main WPML plugin, but now I know it was you.

Probably you noticed the site faster because I disabled it. Not sure, will do my tests tomorrow after my support staff is done uploading files to the site. Will keep you updated.

April 29, 2021 at 5:41 am #8650521

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the feedback.

I was working on staging21, shouldn't that website instance be for our testing only or?

I was doing testing on that instance, with myself enabling/disabling and testing it that way, as you can see in the video, it wasn't affected by any 3rd user activation/deactivation of plugins.

Please check and make sure to clarify bit this up to us, are we checking and working on the same website?

Thanks,
Drazen

May 6, 2021 at 6:17 pm #8708207

jeffreyV-9

Hi.

We use that staging site to prepare everything WPML-related and add translations. When we have all translations ready and the WPML slowness fixed, we'll move the data to our live site.

It is safe for you to log in, our team finished uploading the documents.

I didn't notice any speed improvement. Please note: we experience a slow page load, and then a few regular-speed page loads. Specifically, when you first log in, it takes several seconds to load.

Also, I noticed that disabling the translation management addon does not solve this.

It's ok if you prefer to take a copy of the database for testing on your side.

May 7, 2021 at 6:43 am #8710687

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for checking with our developer who is working on this case.

Will update you soon.

Kind regards,
Drazen

May 11, 2021 at 8:51 am #8736269

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

In order to reproduce the issue, you can create a simple script using WP-CLI that adds at least 300,000 dummy WordPress users, then you'll notice the issue.

1) Our developers tried to reproduce the issue as you described, but it works fine for us. Would you be interested in reproducing the issue if we provide a test site?

2) Can you please check if the slowness still happens when only WPML plugins active, all other disabled, and using the wp default parent theme, not a custom child.

3) On the staging site you have provided, we can only see slowness while logging in, around 9s. Please share video of the issue happening in other cases. It could be you are dealing with a hosting issue or low resources.

Please let me know.

Thanks,
Drazen

May 11, 2021 at 6:51 pm #8742925

jeffreyV-9

1 - Sure, I can help you reproduce it using your test site. Actually our site is reaching 600,000 users.

2 - We have other staging sites with same data and without WPML, no slowness.

3 -
"WPML Multilingual CMS" plugin enabled = Slowness only when logging-in.
"WPML Multilingual CMS" + "Translation Management" plugins enabled = Slowness on all pages within wp-admin.

The topic ‘[Closed] Split: My site dashboard is extremely slow with WPML enabled’ is closed to new replies.