This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
October 7, 2019 at 6:30 pm #4710173

alexandreB-39

Hi Bobby,

Thank you for your help.

I had another problem when you resolved it, all my pages (except the homepage) were blank with 404 error.

So I created a .htaccess file in the server (apparently there was nothing) with this code, and it resolved the problem:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

Now I have an other problem: the pages are now translated and I have access, but the titles of the pages in the header won't translate !! It stays in french, I don't understant because I s-translated everything, also the titles.

Thanks in advance.

October 7, 2019 at 7:07 pm #4710329

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I have created a test page called WPML Test FR, the translation of its Title is working as expected.

hidden link

Your page "About-Us" for example is set to 61% translation , if possible get it to 100% and save, then let me know your results, please.

October 8, 2019 at 6:45 am #4712533

alexandreB-39

Hi,

Indeed your test page is working, but mine are not.
I finished the translations completely (100%) and it's still the same, the header titles are not translated.

I already tried a few times and it's never working.

"Accueil" is still "Accueil" and needs to be "Home"
Same about "A propos de nous", needs to be "About Us"

Thanks in advance.

October 8, 2019 at 6:54 pm #4717711

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

The Title itself is indeed translated for the "About us" page , as if you examine the page tab you will notice that its "A PROPOS DE NOUS" for French and "ABOUT US" in English, but the title is not showing on the page because it's hidden from within the page settings.

Below you will find the steps I followed to enable the Title to show in the translation:

1. Go to Pages->Edit "A PROPOS DE NOUS" page.
2. Use the language switcher in the top header to switch to English and remain in the WP editor
3. Scroll down to "Option de nd page"
4. Set to show title

This has most likely happened because your custom fields are set to "do not translate" rather than "copy" , which would have copied the default settings to the translation.

I recommend setting them to "copy" to avoid such issues in the future.

NOTE: I have also resolved the issue with the menu translation as well by adding your EN menu as the translation for the FR menu.

October 9, 2019 at 7:48 am #4720349

alexandreB-39

Great, thanks for all the precisions, now it works for the translations of the titles.

The thing is that now I have 2x "HOME" in the english version but not the french version.
+ I translated the "CONTACT" page and it doesn't appear in the english version.

/!\ Can I please ask you to help me asap as I have to promote this website this evening.

October 9, 2019 at 4:37 pm #4724467

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

To resolve such issues you can go to Appearance->Menus->Select the correct menu and its language and view it -> Edit it as desired.

I have now sorted your menu and it looks to be as expected, please confirm with me.

October 10, 2019 at 6:24 am #4727539

alexandreB-39

Everything is OK now. Many thanks for your help and your patience!