This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Itamar 4 months, 1 week ago.

Assigned support staff: Itamar.

Author Posts
June 17, 2019 at 3:09 pm #4036463

bei-xianK

3. Post Types Translation and Taxonomies Translation settings are not saving properly.
I would like to make my Media and Post not translatable so I have gone to the settings to try to make them non translatable. However, when I click save and waited for it to save, and then refresh again, the settings went back to Default.

June 17, 2019 at 3:28 pm #4036659

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see this issue on your site. Please update WPML to its latest version currently 4.2.7.1 and see if the issue persists. If it persists then, please try the following procedure. I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible, get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like Twentynineteen and no plugins activated except WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentynineteen (for example). If it persists then deactivate all plugins except the WPML and its add-ons. Then please check if the problem persists. If it does not persist, so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

The topic ‘[Closed] Split: Post Types Translation and Taxonomies Translation settings are not saving properly’ is closed to new replies.