This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This topic contains 8 replies, has 3 voices.

Last updated by Lauren 1 month ago.

Assigned support staff: Lauren.

Author Posts
February 14, 2020 at 5:48 pm #5496233

karlap-2

Thanks for your reply. I have another issue, midly related to this current issue. Do I open another ticket or we continue on this one?

Anyway. The issue is that when running the Imports (WP All Import with WPML All Import installed) sometimes the properties appear as published but no properties are visible. I have to go to WPML Settings > Post type Translation and save Houzez Properties as translatable (It's already set but I have to do it again). After that, ALL the properties are set in English, so I have to run the imports again to set the properties in their respective language.

Why does this happen? How can I prevent this?

On the imports I have correctly set the language of each translation and how to match it with the original language by an unique field.

February 17, 2020 at 7:32 pm #5510143

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support and sorry for the bit of waiting here due the weekend. It is really complex to determine what's preventing WP All Import of working as it should in your particular case as it seems to be something website specific. I would recommend the following test:

1 - Disable all the plugins except WPML related ones and those directly with your theme functionality such as post type, page builder etc.

2 - Run WPML All Import with just one test post.

3 - Make sure when published the property post has the same settings for both the default language and translated properties. As these properties settings are defined in custom fields, chances are during the import process some settings are not being consistent.

See: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Please, let me know the results, have a nice day.

February 17, 2020 at 8:51 pm #5510635

karlap-2

Hi, thanks for your reply.

However, there's no Custom field translation setting. Only Post type, taxonomy and media translation on WPML > Settings.

February 18, 2020 at 5:50 pm #5517665

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

February 19, 2020 at 1:10 pm #5524011

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. A look at your WordPress Dashboard confirmed you don't have the 'WPML Translation Management' addon installed which is something required to set the translation preferences for custom fields, please, make sure it is installed and activated from your WordPress Dashboard > Plugins settings.

See: https://wpml.org/documentation/wpml-core-and-add-on-plugins/

Please, let me know if it helps, have a nice day.

February 19, 2020 at 5:02 pm #5526205

karlap-2

There's no Translation Management plugin available for our account.

We've been using the same account for the same site on other server previously and didn't have any problems. The issue we're facing is that sometimes the properties are imported and on the list thay say published but they don't appear on the list.

The required plugin would be WPML All import to correctly set the language for each property imported and how to locate the original with its ID.

February 20, 2020 at 5:58 pm #5535631

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. So you are saying the same procedures worked for other sites even with WPML Translation Management disabled, right? In this case, let's proceed with some tests:

1 - Do you see the same issue if importing a regular post/page (not the property post type)?

2 - Can you please try to import just one property post and confirm if it work and appear published properly?

Also, please, review our instructions carefully on how to proceed with the import process at: https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

Please, let me know the results, have a nice day.

February 23, 2020 at 3:28 pm #5549121

karlap-2

To answer you questions:

1. We only import properties in our case. The external XML file only has properties. No other post type.
2. We need to set up another wordpress installation to import just one property and we need to edit that XML file to reflect that. We plan on doing it this week. We'll let you know.

February 24, 2020 at 8:40 pm #5557397

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi there, Marcos is off for a few days, so I'll be keeping an eye on this ticket while he is away. I'll look for your update after you are able to test the import.

The Translation Management plugins is what controls how custom post types, custom fields and taxonomies are set as translatable or not. This is why you are not able to save the Property post type as translatable. I also don't think that the external xml file will work correctly without the Translation Management plugin active. Let's see how your test import goes and we can continue once we know those results.

The topic ‘[Closed] Split: Prevent duplicating media for properties images on a real state site’ is closed to new replies.