Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.26 hours from now. Thank you for your understanding.

This topic contains 17 replies, has 2 voices.

Last updated by kevinN-13 6 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
April 24, 2019 at 6:06 pm #3675773

kevinN-13

Hi. again I make this process but i can't see all the products in the english version I hope you can help me again

thanks for all the support

April 24, 2019 at 6:24 pm #3675841

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please check the screenshots, English products are displaying for me. So please let me know the exact steps to reproduce the issue on your site.

hidden link

hidden link

--
Thanks!

Bigul

April 24, 2019 at 6:45 pm #3676007

kevinN-13

Well, I 'll send you the screenshots of the problem and compare the english and spanish version of the shop:

hidden link
hidden link

and this problem was in every category and in some categories for example show other things

hidden link
hidden link

April 24, 2019 at 10:28 pm #3677361

kevinN-13

For example I enter in the translate management and I upgrade the translations of this products but still in the same state, And I think is related with the problem we have

I send you this screenshot

Thanks

April 25, 2019 at 2:00 pm #3683149

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. This may be happening because of the compatibility issue. Please switch for a moment to WordPress default theme like 2017 or 2019 for a moment(after a full site backup) and check the issue is existing or not.

In Translation Jobs list there are many translation jobs has sent to the specific user. But they are not listing in WPML>>Transltions queue. Please check the attached image.

Therefore I have a request to collect more information. Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

April 25, 2019 at 3:08 pm #3683741

kevinN-13

Hi, I followed your steps but I did not get any results:
change the theme with no success
I modify the wp-config file and I did not throw any errors

I hope you can help me as soon as possible cause we need to start selling products this weekend

thanks again

April 25, 2019 at 5:56 pm #3684879

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. It requires further checking. So Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

April 25, 2019 at 6:10 pm #3684901

kevinN-13

The plugin was installed, you can enter to do your tests

I'll be here

Thanks

April 26, 2019 at 6:12 am #3687965

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy of the site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

April 26, 2019 at 3:04 pm #3691779

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, I have tried the following steps in my local copy and the products and categories are loading as expected now.

Please try it after a full site backup and let me know your feedback.

1) Upgrade to the latest version of WooCommerce and WooCommerce Multilingual

2) Go to WPML>>Support page

3) Click on Troubleshooting link (blue link in the middle of the page)

4) Please choose *Products* from the Post Type field and click on *Synchronize posts taxonomies* button

5) Then click on the following options of the *Clean up* section of Troubleshoot page. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

6) Visit WooCommerce>>WooCommerce Multilingual>>Status and click on Troubleshooting link

7) Click on *Start* button of *product_type* taxonomy

Please check the attached image for more details and let me know your feedback.

--
Thanks!

Bigul

April 26, 2019 at 6:22 pm #3692801

kevinN-13

Hi, Again it seems it functions now we have only two little issues first the
hidden link shows 3 subcategories but it need to be 4(with tarjetero) this in spanish version
hidden link shows all the products it need to show only the 4 subcategories

Now in the bags categories in spanish version
hidden link we have 9 subcategories
hidden link only shows 8 subcategories we hope you can help us with this issues

thanks a lot, have a nice day

April 26, 2019 at 10:00 pm #3693411

kevinN-13

Hi,

I see again the issue and some categories doesn't appear in english version
I'll send you this screenshots

thanks for the support

April 29, 2019 at 10:28 am #3702079

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. The issue is existing for me after the initial debugging procedures. Therefore I have forwarded the details to our second tier team for the expert opinion.

We will get back to you as soon as possible. Please wait. Sorry for the delay happened because of the weekend.

--
Thanks!

Bigul

April 29, 2019 at 3:23 pm #3704895

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, the Accessories Product Category Archive is showing the expected result in English on my local copy after the following steps. Please try it after a site backup and let me know your feedback.

1) Visit WooCommerce>>Status
2) Click on *Tools* tab
3) Switch dashboard language to *English*
4) Click on *Recount terms* button
5) Then visit the Accessories Product Category Archive page

--
Thanks!

Bigul

April 29, 2019 at 4:24 pm #3705463
kevinN-13

Perfect, we are so close to finish this issue, Now we see this differences between the versions

for example in english version there are fewer sections in the shop menu than the spanish version

ill send you the screenshots

thanks a lot

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-shop-menu-is-missing-items-in-english/