Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The qTranslate Importer plugin does not recognize the languages that are defined in qTranslate-X and therefore not show them at the beginning of the importation process.

Solution:

This issue is escalated to our developers for them to debug it. Nevertheless, if you proceed with the importation process, the languages from qTranslate-X are being imported correctly to WPML.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Relevant Documentation:

https://wpml.org/documentation/related-projects/qtranslate-importer/

This topic contains 18 replies, has 3 voices.

Last updated by Itamar 1 year, 5 months ago.

Assigned support staff: Itamar.

Author Posts
May 21, 2018 at 8:01 am #2199201

viljoM

Hi,

I have very similar problem and I have not figured out how to fix it.

The importer plugin gives me this note: The following languages will be imported: . will be set as the default language.

I've checked the php and WordPress versions (they are ok) and the memory settings, too (as well ok). I did put all languages to English (just in case) instead of Finnish. Still - the imported languages are set to be nothing. Some of the minimum requirements for WPML were too advanced for me to check.

One difference compared to case the above is that I am using wordpress multisite.

I just don't dare to do the conversion before I can see the languages on the line.

At the moment I enabled qtranslate x back as it was so my visitors are having some kind working site to look at.

May 21, 2018 at 8:04 am #2199279

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Thank you for contacting the WPML support forum.

I've split the ticket where you have added this comment to a new ticket. This way it will be easier for us to handle this issue.

Are you using the latest version of WPML and our bridge plugin WPML All Import?

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations.
We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

Thanks,
Itamar.

May 21, 2018 at 9:12 am #2199845

viljoM

Hi,

As a new customer to WPML, I have installed the newest version, yes. For importing I did try "qTranslate X Cleanup and WPML Import". So this might be wrong version to use?

May 22, 2018 at 9:36 am #2206491

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for the extra details.

I think that it will be best if I check things on your site. If I need to change anything I'll make a copy of your site and try it on my local server.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.
You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.
** IMPORTANT **
- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link
 
Thanks,
Itamar.

May 23, 2018 at 7:27 pm #2218153

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for the access details.

I've installed the Duplicator Pro plugin on your site to make a copy of it.
Not to break anything while trying to help you with the Qtransalte importer issue, I wanted to check things on my local server. Unfortunately, while creating the duplicator package, the site became unavailable for about half an hour, and the package was not created eventually.
Can you, please try to make a Duplicator package for me and send it to me?
Alternatively, you can send me a copy of your site (files and DB) in another duplication method if you have it.
You can upload it to a service like Google Drive or Dropbox and share the link with me.
For this I'll enable private message for the next reply.

Thanks,
Itamar.

May 24, 2018 at 5:13 pm #2224741

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for sending me the backup of your site.
I'm downloading it now.

About the performance issue that you are concerned with, we have an article in our documentation that explains what you can do to make your site run faster.
Please see it here https://wpml.org/2012/01/can-your-site-run-faster/

I'll keep you updated here.

May 24, 2018 at 9:42 pm #2225793

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

The download has completed.
I'll be able to install the site on my local server and continue debugging the issue on Sunday.

Thank you for your patience,
Itamar

May 25, 2018 at 7:39 pm #2231588
tilmanV-2

Hi there!
Just wanted to let you know that I am having the exact problem and would love to hear when you have a solution. Let me know if I can help by contributing any information.
Cheers!

New threads created by Itamar and linked to this one are listed below:

https://wpml.org/forums/topic/split-split-qtranslate-importer-not-working-another-similar-issue/

May 27, 2018 at 4:34 pm #2235308

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I'm having trouble installing your site from the package that you have sent me.
The DB is very big, and it seems that it holds the data for a few sites.
I need to ask you a few more questions to be able to sort this issue out.
On your site's dashboard, I can see that you have two sites/.
- vapaalehdykka.net
- vapaalehdykka.net/harmonikanrestaurointi
1. Are you trying to install WPML for both of these sites?
2. Which of the DB are for those two sites?
I ask it to see if I can export only the tables of the required sites.
For this, I'll enable private message for the next reply so you can securely share with me this answer. I might try again to use the Duplicator Pro plugin to make a copy of your site once I get the answer from you.
3. Do you have the possibility to create a staging site on your server where I can freely try things without breaking the live site?
This could make things easier if the copying of the site did not succeed.

I've just noticed that you are using the Multilingual Blog plan which does not include our Strings Translation add-on. Please pay attention to what is written in our documentation here.
https://wpml.org/documentation/related-projects/qtranslate-importer/#other-texts-that-you-might-have-to-edit-manually
So according to this last section of our documentation if you have other strings translated with qTranslate that are not texts in posts or pages you will also need the Strings Translation add-on. This add-on is available with our Multilingual CMS plan.
https://wpml.org/purchase/

I look forward to your reply!

Thanks,
Itamar.

May 28, 2018 at 10:56 am #2237895

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thank you for your detailed answer.

I've just had a discussion with our developer who is in charge of the qTranslate Importer plugin. He says that we have never tested this plugin with a WordPress multisite installation, so we do not know how it performs with it. Nevertheless, we can see that also in other cases where it is a regular WordPress installation sometimes the same problem occurs. There are no languages specified when trying to import from qTransalte to WPML with the qTranslate Importer plugin. So I'm not jumping to conclusions now whether it is because of your multisite installation.

Our developer has asked me to check with you if the problem persists when you try the following.
A. Go to the qTransalte settings and re-save the settings for each language.
B. Try to re-import and see if it works this time.

I've also checked other settings that our developer has asked me to check. He asked me to check if the language code for the English (en) and Soumi (fi) languages are the same in qTranslate and WPML. And I can also see that Soumi is configured in WordPress to be site's language. So we are covered in this respect. You also said that you have tried to do the import when English is set as the default language of the site.
When you did, it did you also check that it is set in WordPress to be the site's language?
This part is not so clear to me.

I'll wait to hear from you of the results of this test and the answer to the above question.

Thanks,
Itamar.

May 28, 2018 at 10:59 am #2237901

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Oh and another thing that I'm not sure that you have followed and I'd like to ask you about.
When you try to import, did you deactivate the qTransalte X plugin?
Our documentation states that this is the way to do it.

The best way to do this conversion is to disable qTranslate, enable WPML and the qTranslate Importer and let it do everything automatically.

https://wpml.org/documentation/related-projects/qtranslate-importer/#with-wpml

May 28, 2018 at 12:35 pm #2238518

viljoM

I'll put here all answers you asked:


A. Go to the qTransalte settings and re-save the settings for each language.
B. Try to re-import and see if it works this time.

I have done this few times. No changes. Only thing I found out this time was that I had forgotten to do WPML settings on my second multisite site. Filling the settings did not make any changes to importing.

You also said that you have tried to do the import when English is set as the default language of the site. When you did, it did you also check that it is set in WordPress to be the site's language?

Yes, I did. However, a minor note is that even if the site language is set to Finnish, WordPress does not translate the admin area to Finnish as it does with non-multisite installations.

When you try to import, did you deactivate the qTransalte X plugin?
Yes. I followed the guide step by step very carefully in the first place.

The problem still exists. I can not see the languages it could translate. See attachment.

May 29, 2018 at 5:49 pm #2247665

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for providing all the answers.

I've found out that is the last days we have a few other reports about this issue and it is already escalated to our second tier supporter for further debugging.

I can reproduce this issue on a clean WordPress installation. I did not try on a multisite installation, but if it is happening on a regular installation, it is obvious that it will also occur on a multisite installation. I'll repeat the issue now. The importer does not recognize the qTranslate-X languages on the screen. Nevertheless, if I go ahead and press the 'Start' button, the process completes with success, and I can see in WPML the same languages there were set in qTranslate-X.

Can you try if it is working for you as well?
You have written to me: "I just don't dare to do the conversion before I can see the languages on the line." I can understand that so, therefore, it is important that make sure to take a full site backup before you try that. And it is better to try it on a copy of your site and not on the live site.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Please let me know if it is working for you.

Meanwhile, I'm also escalating this ticket to our second tier supporter and adding it to the other escalated similar issue.

Thanks,
Itamar.

May 31, 2018 at 5:51 am #2254432

viljoM

I did what was asked. Small things to do with menu settings so it should be ok (qTranslate menu is still there)

Here is some additional notes which might help you to develop your products better:

There came no rewrite rules for .htaccess for the main site. Also, to get know this, I needed to click another link (in wordpress menu) and then click back to importer tool. However, the secondary site I have in my multisite did get a list of rules to put to .thaccess. This did not include any convert rules for the main site.

Both sites needed to convert seperatelly. WPML did not find .htaccess when clicking the "very my .htaccess file" button. But that was no big deal to make the rewrite rules to .htaccess with file manager.

Only thing what did not convert was the hard coded transalations at gallery. I will have a deeper look on this one still and the whole site in general. Were there instructions to work with this?

If you don't need to have an access to my site anymore, please verify that. I will delete all third party access to the site after your check.

So far I thank you for support I have gotten. I'll put still one message to you after checking everything once more.

May 31, 2018 at 4:12 pm #2257651

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Great! I'm glad that it mostly works now.

Thank you for your inputs about the process.

About the .htaccess issue that you are reporting.
It is weird because according to the following link I thought that a multisite needs only one .htaccess file. But I might be wrong.
https://codex.wordpress.org/Multisite_Network_Administration#.htaccess_and_Mod_Rewrite

About the hardcoded translations, I think that the following link to our documentation (which I've shared here before) is what you need.
https://codex.wordpress.org/Multisite_Network_Administration#.htaccess_and_Mod_Rewrite
If it is hardcoded that there is no other way then to change it in the code.

At this point, I do not need the access to your site anymore.

I'll wait to hear from you if anything else will rise.

Regards,
Itamar.