This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

wyz_business_country field is not being copied to the translation and therefore when searching by location it does not work.

Solution:

Workaround - Translate the business posts manually and set the location field for each translation.

Tagged: 

This topic contains 25 replies, has 2 voices.

Last updated by Itamar 5 months, 1 week ago.

Assigned support staff: Itamar.

Author Posts
April 1, 2019 at 9:23 pm #3511751

ahmedM-19

Hi Itamar,
Thank you for your response.

I followed your steps exactly as you see in the screenshots.
And yes business featured image appeared finally by this method but still the location is missing so the new business i added didn't show up in the search results by location.

Waiting for your feedback.
Thank you so much.

April 2, 2019 at 5:01 pm #3519279

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

When I try it now, it is working for me. I filter the Arabic search to (أونلاين بيزنس), and I can find the Dahil business on the second page. Please see the attached screenshot.
Can you see that it is working?

Regards,
Itamar.

April 3, 2019 at 1:54 pm #3526771

ahmedM-19

Hi Itamar,

These are the businesses that I edited manually twice, one in the translation editor and another in the translated business itself.

I told you 5 days ago that
"It works but it will take a lot of time to insert logo and location in more than 7000 businesses. Do you have any other option to save time!"

April 4, 2019 at 5:49 pm #3537447

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm sorry, but I do not have another idea of how to save time with this issue. I'll escalate this issue to our compatibility team, and they will try to find a fix for this. It looks like this theme has changed since we last checked it so it might be that cooperation with the theme author would be needed. I'm escalating this ticket to our compatibility team with this issue: "wyz_business_country field is not being copied to the translation and therefore when searching by location it does not work."

I'll keep you updated here for any news.

Thank you for your patience.
Itamar.

April 4, 2019 at 9:11 pm #3538683

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

This ticket is now escalated to our compatibility team.
We'll keep you updated here.

Thank you for your patience.
Itamar.

April 5, 2019 at 3:34 pm #3545351

ahmedM-19

Thank you so much Itamar

April 8, 2019 at 11:17 am #3557049

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Update
I'm still waiting for our compatibility team response. When they'll check this issue I'll reply here.

Thank you for your patience.
Itamar.

April 9, 2019 at 3:33 am #3562779

ahmedM-19

Hello,
Thank you Itamar for your dedication.

I am working manually to translate businesses now.

If I want to open a ticket to solve the problem of opening the Arabic home page in mobile devices, what would be the subject please.

Thank you

April 9, 2019 at 2:18 pm #3567865

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I would say it can be "Arabic as second language homepage on a mobile device issue"

Regards,
Itamar.

April 9, 2019 at 7:04 pm #3570201

ahmedM-19

My issue is not resolved.

April 10, 2019 at 8:48 am #3573653

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You have marked this ticket as resolved. If you still need help with this issue, please reply here.

Good luck with your web projects 🙂
Itamar.