This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: 404s on the translated sub-categories

Solution: The Update for WPML 4.2.6 solves this issue.

Relevant Documentation: https://wpml.org/2019/04/wpml-4-2-6-faster-string-translation-for-busy-sites/

This topic contains 28 replies, has 3 voices.

Last updated by helenaG-4 5 months ago.

Assigned support staff: Andreas W..

Author Posts
March 4, 2019 at 11:35 pm #3270871

helenaG-4

I've tried to create a copy of my website with Duplicator, but it doesn't work. But I've decided to not use that line of text on blog posts either so I don't need help with that anymore.

However, did you see my message about subcategories gone missing?

After installing WPML my subcategories are giving me a 404 error. The posts are still there but the categories just seems to have disappeared. How can I fix that?

March 4, 2019 at 11:38 pm #3270874

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Did you check if the categories are translatable at WPML -> Taxonomy Translation?

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

March 20, 2019 at 2:43 pm #3389149

helenaG-4

Yes, they are translatable and I have translated them. It's not only in the translation it doesn't work, but even in the original language.

I have tried to use Duplicator but it doesn't work and only messed up the site for me when I tried it, so please do not use it. You are however welcome to check and see if you can find the problem.

March 20, 2019 at 2:44 pm #3389157

helenaG-4

Also, I did not see the private box.

March 20, 2019 at 3:00 pm #3389503

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for your message.

Please fell free to provide the credentials again. If necessary we might be able to migrate your site directly to our test server.

Kind regards
Andreas

March 20, 2019 at 10:01 pm #3393737

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Do I understand right that the issue is solved once WPML is deactivated?

Your current version of WPML is outdated. It might be that the issue has been solved in a latest update. Please update WPML and its add-ons to the latest version and let me know if the issue persists.

You can update WPML by going to Plugins -> Add new -> Commercial.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

Kind regards
Andreas

March 21, 2019 at 12:19 am #3394047

helenaG-4

I've always updated when there's been a new update.

And I don't know what happened but now it says my site key is invalid. Can you look into it or should I submit a new support ticket for that?

March 21, 2019 at 12:20 am #3394051

helenaG-4

It looks like this.

March 21, 2019 at 12:23 am #3394107

helenaG-4

And like this when I go to the Plugins -> Add new -> Commercial

I don't know what's wrong because my site is registered already?

March 21, 2019 at 12:26 am #3394133

helenaG-4

And no, it doesn't seem to get solved when WPML is deactivated. But the problem started when I activated the plugin.

March 21, 2019 at 2:30 pm #3407505

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please go to https://wpml.org/account/sites/ and check if your URL is registered here.

Then click on "show key" and copy and paste it on your WP-Admin. In case of any error simply delete the URL from https://wpml.org/account/sites/ and add it again. Then use the new key for registration.

Let me know if this solved the issue.

Kind regards
Andreas

March 21, 2019 at 3:17 pm #3409513

helenaG-4

Thank you. I had to remove the url and then add it again to get it to work. The plugins are all updated now as well. But the problem with the subcategories are still there.

March 21, 2019 at 5:27 pm #3414607

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As far I did check your site there were not any subcategories set at the moment, correct?

Could you please try to run the site in minimal setup to see if the issue persists? My expectation here is that maybe another plugin caused the issue and that once it is disabled your subcategories will appear again.

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

In case you disable all the plugins and you only use WPML will the subcategories appear again? if not, then I might only be able to advise you to create the subcategories again and let me know if it worked out.

Kind regards
Andreas

March 21, 2019 at 5:34 pm #3414901

helenaG-4

There is one subcategory at the moment - hidden link but when you go there it only shows a 404 page.

I will try to see what happens when I disable the plugins I use.

March 21, 2019 at 5:46 pm #3415359

helenaG-4

I've disabled all the plugins that I could and the problem is still there.

And even if I create new subcategories, they will still show a 404 page.