This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Lauren 4 months, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
May 21, 2019 at 8:20 pm #3858733

angelaG-5

But those issues may be caused by removing 'panels_data' and the French site needs to be used by our end customers soon so we need to resolve these ASAP. With the experience and findings you accumulated during your assessment on this issue, it should be less time consuming if you could look into those. I would really appreciate if you could at least fix those issued 2 and 3.

May 21, 2019 at 8:33 pm #3858747

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please reply in this thread for the issue with the layout. You can close the previous ticket, as the original issue has been resolved.

Also, please let me know the results of the test when changing the custom field back to copy.

May 21, 2019 at 8:45 pm #3858755

angelaG-5

Thank you for continuing your support.

panels_data was removed from the data base by the admin of WP last week. When they found out the layout issue, they fixed the issue on the first page (home) and they told me that the custom field is reappeared already. (Those French pages are still showing up ok.) All of those three issues are still there though. It looks like they just fix the first home page but not other pages.

FYI, we translated abou 30% of the entire web site so far and the remaining is being translated for now. My next question is that if I need to remove "panels_data" again (because it reappeared) when I am importing back translation for the remaining pages. (If so, we may try just finding how to fix this and cause but not actually implement since we might need to do this again after importing translation for the remaining pages.

Let me know if you want to take a look at the WP site. I believe I have shared the credential with you before.

May 22, 2019 at 2:31 pm #3866707

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I think it's okay if the panels come back as long as the field is set to do not translate in WPML -> Settings. It sounds like the page where the panels field was removed are working correctly, even after the field came back. Is that correct? If so, they will just need to remove the panels, fix the layout for all of the other pages, and then everything should work correctly, since when the panels field returns it will be set to do not translate. Let me know if I am misunderstanding.

May 22, 2019 at 3:38 pm #3867229

angelaG-5

Ok. We will see how importing translation of the rest of the contents will go. But can you let me know how to fix the issue 2 and 3 regarding images and the side menu bar? I spent quite sometime to figure out yesterday but couldn't solve them.

May 22, 2019 at 6:49 pm #3868779

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It looks like the content is wrapped in a div tag that has a panel ID in the original language, but not in the translation. What happens if you set the panel custom field to translate instead of do not translate? Then, try updating the default and then the translation. Does that change anything?

May 28, 2019 at 11:32 pm #3910505

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please try changing the Custom XML configuration in WPML -> Settings:

<wpml-config>
    <custom-fields>
        <custom-field action="translate">panels_data</custom-field>
    </custom-fields>
    <custom-fields-texts>
        <key name="panels_data">
            <key name="widgets">
                <key name="*">
                    <key name="title"/>
                    <key name="text"/></key>
            </key>
        </key>
    </custom-fields-texts>
</wpml-config>

After this, please let me know if the translations are working correctly. Thanks!

May 29, 2019 at 12:05 am #3910583

angelaG-5

Thank you! What is this supposed to fix among the following issues?
1) Page layout
2) Image not showing
3) Sidebar not showing

Should fix all of them?

May 29, 2019 at 12:32 pm #3915385

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Yes, I think this will resolve all of those issues. Please let me know if it does not.

May 29, 2019 at 11:09 pm #3918971

angelaG-5

Unfortunately, there is no change. All of those three issues are still there.

May 30, 2019 at 5:11 pm #3925281

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It works when you update the page via WPML Translation Editor. This is because, when you view the page in default language, you can see the content in the SiteOrigin page builder. However, when you view the translation, the content is not in the page builder mode. This is likely because originally it was set to use the Translation Editor, which is recommended for page builder content. So, if you switch back to using the WPML editor, you will see the new page builder fields. I did this on the homepage. I then simply copied and pasted the translated content that had been entered manually, marked each section as complete until the page showed 100% translated and saved the changes. Now you can see the homepage layout is correct. hidden link

You can follow these same steps for the other pages that have problems.
1. In the default page, enable the WPML Translation editor
2. Edit the translation and add the translated content to the correct field
3. Make sure page shows 100% and save changes.

Please let me know if you need any further assistance and I will be happy to help.

May 30, 2019 at 7:54 pm #3925957

angelaG-5

Thank you. The French homepage looks good indeed. I tried with the page below. But it doesn't work. Could you try it? The two issues I am trying to fix. 1) Sidebar menu to show 2) the space between the image and the page title to show. (Space above "Un guidage nouvelle génération à chaque point stratégique.")

hidden link

May 31, 2019 at 2:46 pm #3931285

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I don't see a space above the title in any of the languages. Can you send me a screenshot of what you are seeing in English and what difference you see in French?

The reason the sidebar menu was not showing in French is because you had set the widget to display for a specific URL, which was the-difference. You just need to add the translated URL - as you can see I added the following and now it displays:
the-difference
the-difference/*
fr/la-difference/*

You will need to add the URL for Spanish as well.

Please let me know if you need any further assistance and I will be happy to help.

May 31, 2019 at 3:33 pm #3931735

angelaG-5

Regarding the space issue above the title, the issue is there is no space. Most of the pages space is deleted for some reason. Please see the correct spacing in the attached picture.

Regarding the sidebar issue, where do I specify the path? I can't find the widget setting.

May 31, 2019 at 5:34 pm #3932427

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I'm not sure this is related to WPML. If you temporarily disable WPML, does the space display?

I think the issue is that your main The Difference page shows div tags (you can view these by clicking "text" in the page editor.

The lower level pages under The Difference do not show these div tags. Try copying and pasting the div tags and see if that adds the space. If this does not resolve it, and disabling WPML does not resolve it, then it is likely an issue with the page builder or theme that you are using.