Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
I can't change the language on the mobile version, the current language is the only clickable item in the language switcher.

Solution:
This happens because on mobile you do not have a hover option. You need to create a separate mobile menu and change the WPML switcher to a list instead of a dropdown.

The issue was fixed for mobiles with the following steps:

1. Create a new menu for mobiles and translate it
2. Add a new language switcher to the mobile menu
3. Set the Language menu items style to "List of languages" instead of "Dropdown"

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.62 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by ralitzaW 1 year, 4 months ago.

Assisted by: Mohamed Sayed.

Author Posts
October 23, 2022 at 8:16 pm #12295921

ralitzaW

Hi! May i ask you to check why I can't change the language on the mobile version only?
On the desktop, there is no such problem.
You may see the video here - hidden link

October 23, 2022 at 9:20 pm #12295965

Mohamed Sayed
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I think this could be an issue with the theme because the parent menu item with the current language is clickable.

Could you please enable the footer switcher in WPML > Languages > Footer language switcher and then check if it works on mobiles?

October 24, 2022 at 2:59 pm #12301605

ralitzaW

Hi! I did it and see it on mobile and desktop in the footer. The only main menu still is the problem.

Regards!

October 24, 2022 at 3:12 pm #12301673

Mohamed Sayed
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Since the footer language switcher is working on mobile, then it's most probably an issue with the theme. Please try the suggestion from my colleague here: https://wpml.org/de/forums/topic/language-switcher-in-mobile-menu-not-usable/#post-12009307

If the issue persists, I suggest contacting the theme author and checking the issue with them (Maybe they can provide a quick fix).

October 25, 2022 at 10:57 am #12306389

ralitzaW

Thanks!
This is the reply from theme support:
This happens because on mobile you do not have a hover option. You need to create a separate mobile menu and change the wpml switcher to other than dropdowns.

October 25, 2022 at 12:04 pm #12307019

Mohamed Sayed
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

In this case, you can fix the issue for mobiles with the following steps:

1. Create a new menu for mobiles and translate it
2. Add a new language switcher to the mobile menu
3. Set the Language menu items style to "List of languages" instead of "Dropdown"

Screenshot_414.jpg
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.