This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bruno 1 year ago.

Assigned support staff: Bruno.

Author Posts
September 12, 2018 at 7:10 am #2726301

Theo

Hi Yvette,
thank you. It works now. When I create a new post with attached media, should I check this box?
Duplicate uploaded media from original
Also I was wondering if you were so kind to help me with the widget translation not showing up since you already have my login data?
Best Regards

September 13, 2018 at 5:45 pm #2732504

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. I would be very happy to help you but I didn't fully understand what is the issue.

When you want the secondary language to use the same images as the original language, you must duplicate these images while holding down the "Duplicate uploaded media to translations" option.

About your second question, can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Note: please let me know if you would prefer me to forward your ticket to Yvette.

Thank you.

September 14, 2018 at 5:17 pm #2736254

Theo

Hi Bruno,

unfortunately the WPML support ticket system is very annoying. I have several different problems with WPML and seem to need a ticket for each one of them. Even if they might be connected.
Anyways, maybe you are the one supposed to help me with the following issue:

I ran the plugin force-regenerate-thumbnails for a specific image name (because there are a lot of old cropped featured images on my website). Now the featured image of the post in one language is missing but shows up in another language. Even tough in the translated post the featured image is set and shows up. On the post where the featured image is missing you can see the featured image in the admin page but on the front page the URL is still of the old image. It seems like somehow there is a cache that not gets updated or so…

(Since I want to run the plugin on the whole media library I need to make sure that both languages show the correct featured image automatically.)

Please help me

September 15, 2018 at 6:32 am #2737292

Theo

I noticed that even if I click "remove featured image" and select the image from the media library again and then click save the URL of the featured image in the blog overview is still the old one where the featured image is missing. It does not matter in which language I do that.
The only way I could get the featured image to show up is uploading it again and selecting the newly uploaded one…
You can see the missing featured images if you go to my english site and search for "Vermona".

September 16, 2018 at 12:14 am #2738128

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Sorry for the delay. Have you tried duplicating/sync these images in WPML > Settings > Media translation?

- Click on the WPML > Settings > Media translation
- Make sure the options below are checked:
[X] Translate existing media in all languages
[X] Duplicate existing media for translated content
[X] Duplicate the featured images for translated content
- Click on the Start button

This will duplicate the registration of the images for the secondary languages. After following these steps, make sure the images are displayed correctly.

If after these steps the problem persists, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 20, 2018 at 5:29 am #2750769

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Sorry for the delay. I noticed that you are using the "Enhanced Media Library" plugin, which changes the way the media works.

This may be causing the problem you are reporting. Accessing your website and looking at the source code I see that the images are added, but with the wrong URL. I'll attach an image for you to see.

To be able to try to look at what may be wrong, please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

September 20, 2018 at 8:48 am #2751476

Theo

Hi Bruno,
yes of course. If you delete the data when you are finished please go ahead 🙂
Thanks!

September 22, 2018 at 5:21 am #2757111

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I installed Duplicator on your site and tried to verify the problem, but it looks like all the images have already been fixed. Both in the Duplicator package and on your site.

Have you fixed these images that were missing? Is there any other post with the problem so I can test the issue you reported initially?

Thank you.

The topic ‘[Closed] Split: Translated pages do not show the correct media name and widget translations’ is closed to new replies.