This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bigul 1 week, 5 days ago.

Assigned support staff: Bigul.

Author Posts
August 19, 2019 at 3:10 pm #4417051

alecC

Hi Bigul,

As you can see I have 35 sites running on WPML and rising. I must therefore be able to rely on your solution as well as on your support in order to solve issues when they arise. The current client has a huge problem with WPML and currently uses more than 8 languages on his sites. Beside the issue that we can not update his site, we also found out the even on the current versions there are major synchronization issues on his page. (that is the version I have provided you with the backup)

Please have a look at the following videos describing the error in a detailed way:
hidden link
hidden link

I very much hope for your reliable and swift support as well as for a expedited solution.

Thank you for your understanding.
Best
Alec

August 19, 2019 at 3:38 pm #4417165

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This issue is only happening with the Polish pages/homepage? Please share me the URLs of the few other pages/posts facing similar issues.

Please update the staging site with the live site version. So we can troubleshoot the issue without affecting your live site.

--
Thanks!

Bigul

August 21, 2019 at 12:10 pm #4431133

alecC

Hi Bigul,

the issue persists also with the Russian version of the home page, as well as with other versions of the home page.

In my prior version I have provided you a download link with the actual live site, so that you can go ahead and make your tests there. I will not update the staging with the old one, hence the staging has the updates on it, where I sill expect your solution on.

Please let me know if you can work with the already provided material.
Thanks
Alec

August 22, 2019 at 9:39 am #4438051

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

Thank you for the updates. I have checked again. The backup you have shared is the one before upgrading to WPML 4.2.7. So it will be great if you can upgrade the staging site or share the Duplicator copy of the live site. The Duplicator package can be shared as a Google Drive or Dropbox URL.

--
Thanks!

Bigul

August 23, 2019 at 12:46 pm #4447371

alecC

Hi Bigul,

I have provided you with two actual installations:
1. staging environment with the actual versions of all plugins, which does not work (and is the one from our other ticket).
2. a download link to the acutal version of the live site where the plugins have not been updated yet, which I can not do because of the other open ticket where I still lack a valuable solution.

So please forgive me my bluntness, but you should be already well equipped with all kinds of installations in order to get finally going.

1. I can not and will not update the live site hence it creates other issues which has been not solved yet by your team!
2. We are currently trying to solve the issues with the current live site and the currently installed versions of WPML.

Long story short: my options are very limited right now. I can either update the site and cause other serious issues with the page which have not been adressed yet, or I can maintain the current versions of the the WPML plugins but would still need you to fix the synch issue which occurs there.

If you ask me both of the tickets might be related or might have a similar cause.

Your job is to take your clients seriously and provide a support which appropriate for such a well known WordPress solution as WPML, specifically with clients who actively use and recommend your solution.

You have everything you need (both versions, old and new) in order to do your job and provide me with a solution or at least a proper answer to the problem.

Thank you for your understanding
Alec

August 26, 2019 at 9:59 am #4457325

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

Thank you for the details and Debug information. I had a confusion that you are using WPML 4.2.7.1 on the live site like your staging site. But Debug information of this ticket helped me to realize you are using WPML 3.8.4 on the live site.

I have tried to reproduce the issue on my local server with the backup of the following URL and the latest Duplicator copy of your staging site. But in both cases I am not able to reproduce the issue exactly.

hidden link

So I would like to know, this issue has happened just after you have restored the WPML 3.8.4 backup on the live site or have you made any changes in the restore backup. Please share more information on this.

Sorry for the delay happened because of the weekend.

--
Thanks!

Bigul

August 28, 2019 at 1:30 pm #4474657

alecC

Hello Bigul,

just for clarification, the dropbox link contains the live version of the page, which has not been either updated nor modified. Only the staging version of the page (which is not the dropbox file, but the link you can find in the other ticket) has been updated.

Long story short, the issue persists on the actual live site, which is the exact site as provided to you in the dropbox link.

If you like, please go ahead and try it out on the live site directly.
Please send me a private message option, so that I can provide you with the credentials.

Thanks
Alec

August 28, 2019 at 6:31 pm #4476331

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

Thank you for the details. I am enabling the private option for the next reply. Please share me the credentials.

Also please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

August 29, 2019 at 1:44 pm #4481449

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

Thank you for the updates and login information. I made a Duplicator package using Duplicator Pro plugin. Because the Duplicator plugin is showing host build interrupt error. Will cross-check the issue further and get back to you soon. Please wait.

--
Thanks!

Bigul

September 2, 2019 at 5:16 pm #4499381

alecC

any news yet?

September 3, 2019 at 8:06 am #4501823

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Alec,

It looks like the issue is happening because of the translation sync and an older version of the plugins. I am getting the expected result after the following steps in my local copy.

1) Deactivated all other plugins except WPBakery Page Builder, WPML and WooCommerce which need upgrades
2) Complete the translation of Homepage in other languages
3) Update the Home after a minor edit
4) Update the Polish translation

Please check the attached image and let me know your feedback.

--
Thanks!

Bigul