This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Nicolas Angers 6 months, 1 week ago.

Assigned support staff: Diego Pereira.

Author Posts
April 4, 2019 at 5:45 pm #3537395

Nicolas Angers

Hi,

The error is not there, but there no translation...

I translated and duplicated the page and nothing happens (hidden link) , so the plugin is just not working and my client is waiting on me for the translation.

Is there someone that can resolve this?

Thank you Diego,

April 4, 2019 at 6:04 pm #3537575

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

What happens in this case is that on this page:
- The WordPress content field is blank, so the content is not detected by WPML
- Content is being set through page options
- The theme is not copying the page settings to the translation.

You will need to use these steps to translate this page:
- Go to the edit screen of the page (original language).
- Turn off the "Use WPML's Translation Editor" on the right sidebar
- Select your editor preferences and save
- Edit the translation
- Scroll down to the "Page Slideshow" setion and select the same slider of the english version (see screenshot)
- Check if the page settings are the same of the english version (see screenshot)
- Save
- use the steps of this guide to translate the revolution slider: https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-with-revolution-slider-and-wpml/

With these steps I was able to translate the home on the test site:
- hidden link (French)
- hidden link (Original)
PS: The images are automatically removed on our test server, that's why they are not displaying. But you can check that the translation of the text is being loaded.

Please let me know if it worked for you.

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

Kind regards,
Diego

April 11, 2019 at 1:49 pm #3588457

Nicolas Angers

My issue is resolved now. Thank you!