Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:

When deleting the translation the homepage setting changes from a Static PAge to Latest Blog Post.

Solution:

I've found out that the issue of the homepage that is being charged to the latest posts after deleting the translation of it, is an issue that we are aware of. In fact, we have a warning if you try to set a static page to be the homepage and it doesn't have a translation. This warning is showing if you try to set this in Settings -> Reading. This is the same setting as in Appearance -> Customize. But the problem is that in Appearance -> Customize the warning does not show. Therefore I escalated this issue to our second tier supporters and asked to report it to our developers.

Meanwhile, as a workaround, please avoid setting a homepage that has no translation, or set it back to that page after deleting the translation.

Update

This issue is now escalated to our developers.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Itamar 1 year, 8 months ago.

Assigned support staff: Itamar.

Author Posts
February 6, 2020 at 10:14 pm #5442663

bengtR

Hi!

That sounds great!, thanks. But before I test, have you also tried to permanently delete the English translation of the page? Did it work without strange results for the Swedish original page? Of cours, I can test that, but I think it is better if you do that, in case of any problems (which I had).

Best,
Bengt

February 6, 2020 at 10:16 pm #5442673

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

In our forum, we try to keep one issue per ticket. Continuing with one ticket per issue helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster. Therefore, I've split the other ticket and created a new ticket with this issue.

Yes, I can see this problem now. After deleting the English translation of the homepage the Swedish translation is changed and does not look as it used to look. I still don't know why it happens but, I've found out what happens.

After deleting the English translation the homepage setting in Appearance -> Customize -> changes to 'Your latest posts'. Please see the attached screenshot latest-post.jpg. And the page that was the home page 'Start' is OK. hidden link Please see the attached screenshot start-page.jpg. It is possible to restore the home page to what it was by selecting 'A static page' and selecting the 'Start' page.

I'm not sure why this is happening and if it an issue that comes from WPML. To check it please proceed with the following.

I suspect that there is a collision with another plugin that might cause this problem. If possible get your site into a minimum environment. The minimum environment means deactivating all plugins except WPML and its add-ons and the WPBakery Page Builder.
Then check if the problem persists. If it does not persist then start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

latest-post.jpg
start-page.jpg
February 7, 2020 at 7:11 am #5444481

bengtR

Hi!

Thanks!

I activated all plugins except Elementor (you talked about "WPBakery Page Builder", but I think you meant Elementor) and WPML (see image).

The error still persists: start page is changed to latest posts.

Best,
Bengt

active-plugins-wpml-elementor.jpg
February 9, 2020 at 8:35 pm #5456997

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm sorry, yes, I meant Elementor (not WPBakery).

But according to the attached debug information and the screenshot that you shared I can see that you are also using the 'Elementor - Header, Footer & Blocks' plugin by Nikhil Chavan.
hidden link
This plugin is not known to us and might be causing this issue.
Can you please test if the issue persists when this plugin is also deactivated?

I tried to check things on your site but the access details that you gave me before are not working for me now. If needed please share with me the access details again. For this, I'm enabling a private message fro the next reply.

Thanks,
Itamar.

February 11, 2020 at 12:47 pm #5469407

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Bengt and thanks for the access.

On your staging site, I've checked many things. I tried the full minimum environment. Even with the theme changed to 2020. And I also reset the .htaccess file which contained a lot of directives that I suspected that cause this issue. But the problem persists. And also no PHP errors are being logged when I enable the WordPress debug.log.

I'm consulting our second tier supporters about this case. When I have more information' I'll reply here.

Thank you for your patience.
Itamar.

February 13, 2020 at 10:33 am #5485059

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thank you for your patience.

I've found out that the issue of the homepage that is being charged to the latest posts after deleting the translation of it, is an issue that we are aware of. In fact, we have a warning if you try to set a static page to be the homepage and it doesn't have a translation. This warning is showing if you try to set this in Settings -> Reading. Please see the attached screenshot. This is the same setting as in Appearance -> Customize. But the problem is that in Appearance -> Customize the warning does not show. Therefore I escalated this issue to our second tier supporters and asked to report it to our developers.

When I have news regarding this issue I'll let you know here. Meanwhile please avoid setting a homepage that has no translation, or set it back to that page after deleting the translation.

Best Regards,
Itamar.

homepage-set-reading.jpg
February 17, 2020 at 8:51 am #5505431

bengtR

It is easy to work around this issue, but it would be good if it would be solved in the future. Please let me know when it is fixed.

Thank you!

/Bengt

February 17, 2020 at 12:46 pm #5507733

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This issue is escalated to our developers. When there will be news regarding this issue I'll update here.