This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 34 replies, has 4 voices.

Last updated by Alejandro 4 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
June 9, 2019 at 7:53 am #3982467

Mr. Ghost

How can WPML refuse to even look to an issue without given access to site. I've told you which 2 plugins and WPML is causinfg the issue. This is ridicuilus that you refuse to even look at the issue or sent to the dev team. WOW guys what kind of support is this.

With respect sort of your house and solve the issue. This is ridiculous. I will top using WPMl you refuse to solve your conflicts and issues. I've sent you the conflict and issue and you want to see what? You are not using the wp object cache api correctly. Instead of saying nothing and just say you need to have access which makes 0 sense. Show me you guys are using the api correctly.

Since I and the redis cache plugin developer see differently you have to sort it. Instead of keep on forcing users to give access to get any kind of support. I've found the issue and you still refuse to even send this to the dev team.

This is a very strange support procedure you have. I understand to find an issue that it can help. But I've sent you the issue, the conflict, and the cause this is what you need.

I have no energy left to fight in this, you guys refuse to solve a conflict on your side and in WPML.

I'm done with WPML.

June 9, 2019 at 7:57 am #3982469

Mr. Ghost

Instead of forcing users to share sensitive accesses to sites start solving the issue. This is just ridiculous. We can not use WPML with this conflict, so you refuse to refund from before but you even refuse to solve conflicts and issues in your plugin. I have no words for what WPML is doing.

I'm out, this is....

June 10, 2019 at 12:17 pm #3987361

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I checked on different browsers and page 2 is working perfectly, so could you please try using a different browser and if you can see this reply, you should also receive an email, where you can see this reply.

Back to the issue, I don't think you understand my previous reply well.

I asked if you can either
Provide steps to replicate or
Provide login so I can figure out steps to reproduce the error or Ask the Redis plugin developers to contact us using Go Global Program or
Help us to replicate the issue on the sandbox site

So this is not all about access, this is about steps to reproduce the issue, and I am sorry to say that you haven't provided any steps to reproduce the issue or hints (excepts mentioning the issue is with Redis-server), even you aren't providing the details how the Redis-server is set up, wpml is setup and many more.

If you are unable to provide steps to reproduce or help us to find those steps, I will be unable to solve the issue, we have a lot of users in the forum with there problems and it's not practically possible to check for any issues if there is no help/steps to reproduce from the users.

I wish I could have helped you much better here, but without either of this information, we will be only taking back and forth. Being so, I still request you to either provide any of the information I mentioned above to reproduce the issue.

Let me know how you will like to move forward.

Thanks

June 12, 2019 at 12:05 pm #4003965

Mr. Ghost

I'm on the run so don't have time to answer all your lines, but have you tried:

install redis object cache plugin on a server running redis? and then install wpml core plugin and try? And the issue is not redis plugin since they only connect to the wp object cache API and that's when WPML crash since you do not connect to the wp object cache API correctly.

I've send you the cause and how to replicate. But if you install the plugin without even having redis installed on the server of course...

Try this and send me the login to this server with redis and all those plugin installed and I will show you since I'm so tired of your guys procedure and refuse to take responsibility of issues.

I should not be needed to do such extended work to make you fix a conflict in your plugin. It's jsut rediciolous, you do not even check ony our end. Have you even spoken with your developers? I've told you what the issue is and redis cache wp plugin developer wont email you to fix your conflict since the issue is on your end not his.

Step up for once WPML please, this is ridiculous how you force us to find the code you should change for you to even look at the issue. I've told you where you can drink the water but drink the water you have to do yourself...

if you would have been professional at WPML, I can see a lot of users not being happy with WPML in the WordPress communities, even the support approach seems not to be a local feeling on my side. Never experienced this hassle with a plugin, this support approach and not minded to help and solve issues in your own code if I don't point exactly where to change the code.

Bruno at least was a bit more professional and looped in a developer in the thread. But if this is how you approach ticket, bugs, and issues I do not want to be a part of WPML. Since this is one of the worst experienced I ever had. With respect, but you really forgot the end user in your plugin and service and customer support.

1. the issue is not redis server, the issue is how wpml use WP object cache API told you many times. This becomes a conflcit with redis object cache plugin which enables object cache to work seamlessly with the API. But since you use it wrong it creates a conflict in the api and crahs the database and the translasion.

2. How can you say I have not said what the issue is. It has been cristal clear! Redis object cache plugin, WPML plugin and of course a server runnign redis why would you use redis cache plugin otherwise, it becomes useless otherwise. Please try that and show me wiht a video that it works. And please show me you run redis on the server.

3. If you ever looped in or even spoke with one of your developers and they could have a look at the object api they would found the issue.

Let me know how it goes with the redis on your end, since everything seems to work for you.

June 14, 2019 at 4:20 am #4018457

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for providing the instructions. 🙂

I activated the plugins that you mentioned and checked the issue on the same test site I provided yesterday and I couldn't reproduce the issue, you can try to reproduce the issue yourself once.

May I kindly ask you please to open a new ticket for your additional question?

As per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket.

Thanks

June 14, 2019 at 7:45 pm #4023901

Mr. Ghost

I can not see my last reply on the ticket? did you receive it? It was submitted but I can not see it now in the thread? Did you receive it? It was a long explanation of plugins you missed in your replica, plugin versions and me sharing access to our design application for further troubleshooting. And other issues with database tables that are orphan, bloating and redundant.

Please confirm so we can solve this ASAP. WPML cause me so much hassle and problems and I'm tired of not beeing bale to have 1 week out fo 6months without a bug or issue.

June 17, 2019 at 6:43 am #4032425

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can not see my last reply on the ticket?

Your last reply I can view is from June 13, 2019, are you talking about this one. As you mentioned there, I have installed the following plugins.

Yoast
WPML plugins
Elementor
Elementor PRO
WP Rocket
Hide WPWP Hide & Security Enhancer

Let me know if this is the same reply you are mentioning, if any plugins are missing I request you to help us by enabling it on the test sites to speed up the troubleshooting.

Look forward to your reply.

Thanks

June 17, 2019 at 1:22 pm #4035641

Mr. Ghost

No, I see my 800 words reply got deleted or lost. It was submitted stayed there for an hour but then I checked back for your reply and I saw my message was gone.

I told you I can let you in a development and design environment. But it took 3-4days to even get a reply. Can you as soon as possible share so I can share login and SFTP so that we can solve this issue, please?

June 18, 2019 at 3:19 am #4039825

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have enabled the private reply for you.

I also request your permission to disable/enable plugins/themes on your development site.

Thanks

June 18, 2019 at 6:21 am #4040639

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I enabled WPML string Translation + WPML Translation management on the site and I couldn't reproduce the issue here, so could you please check on the test site once?

Also, after connecting the posts, I can see language switcher not pointing to each other correctly, which is solved by disabling/enabling Redis object cache plugin.

Look forward to your reply.

Thanks

June 18, 2019 at 6:03 pm #4045693

Mr. Ghost

Two things here.

1. We don't use string translation and we don't want to do that today
2. We don't use WPML Translation management and don't want to use that plugin. It not built for our type of websites. it's built for bloggers or news websites that only translate a single piece of text areas. For our type of sites, it not suitable. And neither do I like plugins that remove you from working natively within WordPress.

So those 2 things are core things and you solve it by installing plugins we don't use or want? So either is you not troubleshooting at all or you cover it by forcing us to use those plugins? Or you generally force users to use those plugins? Sorry but this was not what I expect from troubleshooting from the wpml support team.

Did you even troubleshoot on our application shared above?

Also, after connecting the posts, I can see language switcher not pointing to each other correctly, which is solved by disabling/enabling Redis object cache plugin.

Can you show me what you mean? ANd disable/enable Redis object cache plugin upon each page connection or translation does not scale or work. Content managers do not have access to this and this is not how it suppose to work. It means it's a conflict between the two plugins as earlier mention. Redis object cache plugin developer has already given his explanation. You guys are still not looking in to for the issue or have been troubleshooting as it sounds.

I expected more but to be honest to me it does not even sound like you executed troubleshooting procedure, to try to find the conflict and issue. Can I get another supporter on this ticket?

June 19, 2019 at 11:05 am #4050971

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I was just trying to understand if that solution is viable for you. I will debug the issue further to see why it's happening without WPML string translation + WPML translation management.

Did you even troubleshoot on our application shared above?

You can check it yourself once, I enabled few plugins, created pages to troubleshoot it.

I again followed the below steps and the issue is not happening anymore:

- Deactivated WPML string translation + WPML translation management
- Created two pages and connected them
hidden link
hidden link
- Both the pages are working without any issues, no 404.

Also, after connecting the posts, I can see language switcher not pointing to each other correctly, which is solved by disabling/enabling Redis object cache plugin.

This was a one time issue on your site, I couldn't reproduce this on my end. I tested again and can see it's showing the switcher correctly on the shared site now, so it seems like a small glitch.

Let me know if this helps.

Thanks

June 22, 2019 at 10:44 am #4070877

Mr. Ghost

The issue here is that you installed WPML plugins that we don't use. They still stored in the database now. You destroyed the way of troubleshooting it on this site now since you most probably installed those plugin before even checking the issue. And those altering the database and might have solved it. But just deleting wpml plugins don't delete the database tables and rows and auto_loads. So technically this might be solved by installing those but I don't want them installed or in the database. We don't use them they are not for us and slow down performance.

So this is just a poor way of trying to solve this issue. You installed plugins we did not use or are planning to use why even? And deleting or inactivate don't delete them from the database.

So now you created extra work for me and I will revert the application to it's stage and please troubleshoot for real with the existing plugins we have. Do not install other WPML plugins we don't use or even want to use.

And what you mention with the language navigation it does not work that we have to enable disable every time that's also a bug you have to solve with Redis object cache. And once again we want to delete all orphan from the database which I will create another ticket for but please do real troubleshooting now. Why even install plugins we don't use don't understand, neither is this included in your troubleshooting procedure these steps install other plugins included?

Sorry but I'm so tired of this issue and all time and energy all WPML issues taken from me, and when I send login you decide to install other plugins I don't understand it. And of course, inactivate plugins is not removing them. I hope you understand how WPML works. You have to delete plugin and delete all tables and rows to clean it.

So please do real troubleshooting this time no other wpml plugins installed, please. And I prefer to not wait days this time for a response. Maybe somebody else answers this? I would like to request another support agent to handle this ticket with your respect thanks.

I see the 404 issues on my two other sites, production, and another staging environment.

And please share urls and any type of information in private. I do not want to be public in this forum. respect our privacy thanks.

So please answer this ASAP so we can solve it and you can get access to the new staging I just created.

Set up so I can share login once again.

June 22, 2019 at 11:02 am #4070933

Mr. Ghost

So this time can I have another support agent thanks. This has taken too long and not been following proper troubleshooting steps, not even internal documents, so with your respect, I would like to have Bruno or somebody else.

I will share another staging environment but please do not install extra plugins and fail with the troubleshooting. This is why I ask for another support agent Bruno is great.

Please set up so I can share login to it.

June 24, 2019 at 2:27 pm #4077969

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I took this ticket since you asked for another supporter (Unfortunately Bruno could not take this ticket because he is unavailable at the moment).

I just wanted to tell you why Shekhar installed and activated String Translation and Translation Management. These 2 plugins are required in order to correctly run both ACF and Elementor. Without them, it's totally normal if the site won't work correctly.

Even if you believe you don't use these 2, The system actually does. It uses them for things like Custom Field translation on a more deep level, compatibility to specific featured, among other things, and it's probable that, without them, things won't work correctly as expected.

Documentation:
- Elementor: https://wpml.org/documentation/plugins-compatibility/elementor/#getting-started

- ACF: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Having said this, i tried to follow the steps i read on your previous answers and i setup a new cloudways staging site with redis cache active, i installed the plugins you have except the ones we don't have on our repository (wp-rocket and WP Rocket and Hide WPWP Hide & Security Enhancer)

I created a new page and translated it and it didn't throw any 404 error.

I will send you a video with the steps that i took and will also send you access to the staging environment so you can check for yourself and let me know what i missed (if you want, you can do the same, a video sometimes helps way more than anything else!).

I also want to apologize for the time spent on this ticket, but please understand that it's virtually impossible to fix an issue when we can't even replicate it on our own. We need to do it somewhere where we have control because we need to check and test many things so we can then send our findings to our developers and they can fix it.

Some tests could be invasive or involve modifications to the configuration of your site, and we can't do it unless we meet our internal requirements. That's why we always ask to replicate the problem on a sandbox site or ask you to migrate the site to one of our sites which you don't want to do.

Please don't take this the wrong way, we really want to help you, but we need your help too because we do not know anything about your workflow, the combination of plugins you have, your server's configuration or how are you using our and other plugins, so there are way too many variables and it's very very difficult to isolate the problem, even with what you've given us so far (which we kindly appreciate, by the way)

Our goal is to first isolate the problem, then find out what's causing it so we can either fix it ourselves or ask a developer to do it (and the methods we always ask serve to this purpose).

Don't hesitate to let me know about the video or the steps i'm missing or doing wrong. i really want to get to the bottom of this.

Regards