If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 34 replies, has 4 voices.

Last updated by Alejandro 4 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
June 26, 2019 at 1:05 pm #4092669

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

It's a requirement because both WPML and Elementor devs deteremined it so, unfortunately we can't really give you more specific details without derailing from the matter in hand: the problem of this ticket.

I'm sorry if you feel that we are too slow, but in this case, you might want to use our chat support. It's still in its early phase but it's given great results so far.

We can't comment on Polylang, but i suppose it's a great tool as well and we're glad you like it.

The access details you provided are not working, i suppose because there is another authentication window before this, but in order to even access your staging environment i need to have your confirmation that we can touch and investigate it.

However, there's a reason behind the creation of our staging environment as well and the video i specifically recorded for you. i want to understand what step i'm missing because i can't replicate your issue as Shekhar didn't either.

We can take a look at your staging, but we can't just guess how to replicate the problem from scratch, and without that we can't really help much, that's why i went ahead and recorded the last video, and created a staging site specifically for you and for this purpose, so you can view what i did and try to let me know what's missing or what am i doing wrong.

Regards.

June 27, 2019 at 5:10 am #4096619

Mr. Ghost

I can not tell how to replicate it is not working and it is with redis object cache plugin and wpml installed.

Important is for you to check on the staging I shared with you guys to see how it occur on our side. But without installing a lot of other plugins.

The access details you provided are not working, i suppose because there is another authentication window before this, but in order to even access your staging environment i need to have your confirmation that we can touch and investigate it.

I shared the auth password in the reply. Did you miss this? There are an auth password and username and then you have login. Please check my reply once again.

Yes, but please login and create a page in main language and then a page in the second language and publish and you will see the 404. The issue appears when connecting the translations.

1. Create page
2. Create translation or click translate
3 Connect translation and/or click publish.
4 Results in a 404.

It's a requirement because both WPML and Elementor devs deteremined it so, unfortunately we can't really give you more specific details without derailing from the matter in hand: the problem of this ticket.

Spoken to them and not what they said to me. Not if not using it for translating what you think we do. We do not use anything in elementor to be translatable. Everything is connected to backend and ACF fields displays data and content. They do not require and demand you to use translation management tool from WPML: That's just your new framework which is something we don't need or want to use. It's built for content, blog, and news 100% content data 1 article block.

It is not built for us, it's out of wp framework and poorly built. There are many reasons why I don't want to use it. And asked elementor and acf and they see no reason for me to use it if I don't want to or feel like. So please share your email from elementors and ACF (Elliot) developers with a good explanation and prove me I'm wrong 🙂

Auth Password Protection:
U: uvafnkpqgs
P: dbRCzws9yZd

June 27, 2019 at 6:59 am #4097009

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I noticed that you are using WP Hide and i think that was the one creating ruckus. there must be a configuration in that plugin that creates a 404 because even when trying to deactivate it (with WPML disabled) i got a 404 error.

However this is what i did in your staging site and i believe you can test it out as well:

1) I created a post and tried to translate it and got a 404 error.
2) I checked your plugins and saw that WP Hide was installed
3) Since Security plugins can do things like aviod PHP writing in files or restrict DB writing access (for security purposes, of course) i thought to start deactivating that plugin first and see how it went

4) I disabled the plugin
5) I tried to follow your instructions and created another post with another translation
6) This time i didn't get a 404 error
7) I checked the front-end page of both source language and translation and both showed fine

Can you also try that on your end and see if that solves the issue for you too?

Afterwards try to enable WP Hide again and see if you also get the 404 error again and in that case, try to disable one by one the options in the plugin and see if one of them stops the 404 error.

Maybe redis + WP Hide + WPML need to be configured in a particular way in order to avoid these issues?

Let me know.

June 29, 2019 at 8:40 am #4111359

Mr. Ghost

Strange since I tested this in one of my first troubleshooting procedures and did not see this.

I've forwarded the combability notice to the plugin developer and will get back to you. We have nothing that should restrict wpml to talk with the database or write in files. But there could surely be a conflict. And if they restricted a core functionality other plugins would have been affected as well.

I'll get back to you as soon as I know more!

Thanks for proper troubleshooting.

UPDATE:
I did disable Hide WP but back then it did not solve the issue. But they released an update yesterday/today and I updated that one now and enabled the plugin and it seems to work.

Create page > translate/connect > publish > 200

No combability with WPML in the changelog but with other plugins we use, such as elementor etc. So might just have been solved by them:

1.5.8
Add reserved option names to avoid conflicts e.g. wp
Always clear any code plugin cache when plugin update
Easy Digital Downloads compatibility
Elementor plugin compatibility
Fusion Builder plugin compatibility
Divi theme compatibility updates
WP Fastest Cache plugin compatibility updates
Check if ob_gzhandler and zlib.output_compression before using 'ob_gzhandler' output buffering handler
July 1, 2019 at 11:31 am #4118461

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

That's wonderful News!

If you feel this problem is already resolved, then you can close the ticket or give me confirmation so i can close it for you.

Regards.