Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 8.89 hours from now. Thank you for your understanding.

This topic contains 11 replies, has 2 voices.

Last updated by poonyalidP 1 year ago.

Assisted by: Long Nguyen.

Author Posts
March 30, 2023 at 2:14 am #13363001

poonyalidP Site owner

Hi,

Today I increase more CPU x 4 cores and RAM x 4 GB to the server.

I found that the blank page problem is gone. I can load all WPML multilingual page.

But I found this error. Please see illustrated.

Also the pending translating job there. Seem waiting and not auto translate.

I have not run the troubleshooting yet.

I found more problem for some products.

When I edit a product in Thai, it says this is the duplicate of Eng and have key locked.
Then I switch to Eng version, but it also says this is duplicate of Thai version. Also have key locked.

It also show that you are editing this product which is in the auto translate process.... something like that.

Really confuse.

Please help check.
Thanks.

March 30, 2023 at 2:21 am #13363005

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi there,

Thank you for contacting WPML support, I'd be happy to help you with this issue.

In this ticket, we can focus on the issue with the WPML > Translations page does not display jobs.

While checking the debug info, I see the Rest API is disabled on your site, please check this screenshot hidden link

Some WPML features rely on Rest API so if it is disabled, they will not work properly. Please enable the Rest API on your site and check this issue again. If you don't know how to do that, please contact your hosting support to ask for help with this issue.
And please read more in the documentation https://wpml.org/documentation/support/rest-api-dependencies/

Look forward to your reply.
Thanks

March 31, 2023 at 5:28 am #13372085

poonyalidP Site owner

Hi,

I still waiting for my Plesk support to help how to enable REST API.

I'm owner of my hosting server. If you can help providing instruction how to enable it, it would be great.

Now the problem is the WPML is not translate,,,,.. scheduling to translate but nothing translate..... everything stuck.

When enter Translation queue, these error are related to REST API disable?

Error = "The Advanced Editor jobs synchronization has failed", "Jobs could not be loaded"

Please see attachment error.

Before this, while REST API disabled, the auto translation still working.

Thanks.

47.JPG
46.JPG
45.JPG
44.JPG
March 31, 2023 at 8:10 am #13373077

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi,

Thank you for your feedback.

>> When enter Translation queue, these error are related to REST API disable?
Yes, there could be an issue on your site and the Rest API is disable. You can also enable the WP debug and see if there is any fatal error in the log that could cause the issue. Please follow the documentation below to enable WP debug on your site and share the log with me
https://wpml.org/documentation/support/debugging-wpml/

Look forward to your reply.
Thanks

April 4, 2023 at 4:32 pm #13402593

poonyalidP Site owner

Hi,

Plesk support system change new login system and had lots of problem.

I just now reconnect to the Plesk support to open support ticket for enable Rest API.

Please allow me some times for Plesk support to give me instruction how to enable it.

Thanks.

April 4, 2023 at 4:50 pm #13402713

poonyalidP Site owner

Hi,

Plesk support test my server and found that the REST API is running properly at my server.

Also the error might be false positive.

Please see their reply in the illustrated attachments.

Please advice what to do next?

Thank you very much.

102.JPG
101.JPG
100.jpg
April 5, 2023 at 2:51 am #13405289

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi,

Thank you for your feedback.

Can you please create a backup of your site and share the file with me? I will try to restore your site on the local host and investigate the issue further. You can use this plugin to create the backup: https://wordpress.org/plugins/duplicator/
and exclude the folder /wp-content/uploads/, upload files are not needed in this case.

Your next reply is set to private to share the info.

Look forward to your reply.
Thanks

April 7, 2023 at 2:23 am #13424209

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi,

Thank you for your feedback.

I've restored your site on my local host and checked the issue. After enabling the debug log, I there is an error with the plugin NitroPack

[07-Apr-2023 02:14:49 UTC] PHP Fatal error:  Uncaught Error: Call to a member function get() on null in /Applications/MAMP/htdocs/butterflythailand/wp-content/plugins/__nitropack__/classes/Integration/Plugin/WCML.php:70
Stack trace:
#0 /Applications/MAMP/htdocs/butterflythailand/wp-includes/class-wp-hook.php(308): NitroPack\Integration\Plugin\WCML->wcml_set_custom_language_cookie('')

Then I deactivate this plugin and go to WPML > Translations, the jobs are displayed as well. On your site, please try to deactivate this plugin and see if it helps.

Look forward to your reply.
Thanks

April 8, 2023 at 12:37 pm #13431313

poonyalidP Site owner

Hi,

Nitropack support send me new hotfix update and not the WPML translation jobs are showing.

But when I click the "Review", the error page occurred.

Please help.

Thanks.

WPML no error 2.JPG
WPML no error 1.JPG
April 10, 2023 at 2:43 am #13435239

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi,

Thank you for your feedback.

I do not see that issue on the local host and your site when reviewing a job, please check these screenshots
hidden link
hidden link

If you experience this issue again, I suggest you can try to clear the cache of NitroPack or deactivate this plugin for a while and review all translations then activate it again.

Look forward to your reply.
Thanks

April 12, 2023 at 5:55 am #13452083

poonyalidP Site owner

Hi,

Seems everything work perfectly.

I have more question about disable auto traslation.

I'll create another ticket.

Thanks.

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.