This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by martinM-27 4 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
May 23, 2019 at 7:14 am #3871955

martinM-27

Hi Bigul,

What setting should I use in order to convert times generated by the ACF Time Picker Correctly?

On this page: hidden link

. . . you will see on the English version that the times (under 'Operating hours' etc.) are correctly displaid but on the Chinese version they come out as 10-character strings.

I created a new user account for you - the login and username details are the same, but there is a new password. I can't see an option to add this as private information, but happy to provide it to you by whatever method you prefer.

Many thanks again,

Martin

May 23, 2019 at 8:11 am #3872405

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Martin,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please create a test Post in Chinese(not as a translation) and make sure you are getting the correct result for *Operating Hours* and *Last Order* fields in the frontend or not.

I am enabling the private option for the next reply. Please share the new site credentials.

--
Thanks!

Bigul

May 23, 2019 at 4:44 pm #3878053

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Martin,

Thank you for the login information and updates. Please try the following steps(after a backup) and let me know your feedback.

1) Open a *Location* post for edit in the default language
2) Scroll down to *Multilingual Content Setup* setup widget on the bottom of the screen
3) Choose *Copy* as the translation preference for the *Time Picker* fields
4) Apply the changes
5) Update Location posts(just resave to refresh the translation settings)

--
Thanks!

Bigul

May 24, 2019 at 12:11 am #3879931

martinM-27

Hi Bigul,

I followed the steps you set out for the Causeway Bay location (I didn't touch the others), but it made no difference. Here are the steps I took:

- I changed the translation option for the Time Picker fields to 'Copy'

- I clicked 'Apply'

- When the green saved message was displayed I clicked 'Update' (Blue Update button)

- The 'update' icon (circular arrows) appeared against the Chinese version so I clicked that and was taken to the ATE

- I saved each field, then clicked 'Finished' and 'Redeliver'

. . . but unfortunately it made no difference.

Martin.

May 25, 2019 at 11:27 pm #3890225

martinM-27

Hi Bigul,

Is it possible to give me an FTP access to this test site?

The theme that's being used on the site I'm working on is a child theme and I don't have (and cannot get) a zip of it, so it would be really helpful if I could upload the plugins via FTP to the plugins and theme directories.

Many thanks,

Martin.

May 27, 2019 at 6:16 am #3893663

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Martin,

Thank you for the updates. Please click the *WP Sandbox* menu of the dashboard, on the bottom of *Sandbox* page you can find the *SFTP Credentials*.

Please check it and let me know your feedback.

--
Thanks!

Bigul

May 28, 2019 at 2:39 am #3902107

martinM-27

Hi Bigul,

Thanks for pointing me to the SFTP credentials!

I uploaded the plugins and themes and created a new location for Causeway Bay and the translation works correctly.

What is my next move..? To delete all the translated locations and re-do them from scratch..?

Can you just confirm the correct settings - I believe the correct steps for translating posts where Advanced Custom Fields are involved is to:

1. Edit the English version of each Field Group and click Duplicate

2. Edit the English version of individual locations (custom post types) and click Translate

3. Edit the English version of Pages (and normal blog Posts) and click Translate

Is that correct?

In the Multilingual Content Setup module, system generated fields should be set to Copy, and Text or Text Area fields should be set to Translate.

Is that correct?

Many thanks for your patience and help!

Martin.

May 28, 2019 at 1:14 pm #3907269

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Martin,

Thank you for the feedback. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

4) Then update the Location Posts and its translations

--
Thanks!

Bigul

May 28, 2019 at 11:30 pm #3910501

martinM-27

Hi Bigul,

That did the trick - many thanks for your patience and help!

Cheers,

Martin

May 28, 2019 at 11:31 pm #3910503

martinM-27

My issue is resolved now. Thank you!