This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 10, 2018 at 8:30 pm #2805757

dharmendraC

Hello. I have another issue on my site hidden link

In english version the properties are not showing up.

If you click the turkish version, it shows properties.

Can you help me with this issue?

Thanks

October 11, 2018 at 4:15 pm #2809093

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Can you please tell me how you are creating these properties? I don't see an option in the backend of your site to publish properties. I also checked on WPML -> Settings and I don't see "Properties" as a post type. If it were there, you would need to make sure it is set to Translate or Fallback to default.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

October 13, 2018 at 9:10 pm #2814520

dharmendraC

There is an option where you go and publish your properties in my admin panel. WPML -> Settings there is property as post type and I set it to Translate or Fallback to default. Please see the attachment for confirmation.

October 15, 2018 at 12:55 pm #2817539

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I see. The credentials in this ticket that were provided by the previous supporter are for a different website, which would explain why I can't see the properties.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 15, 2018 at 4:12 pm #2818235

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for allowing me access. I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved?

If not, go to WPML -> Support -> Troubleshooting. Look for 'Clean up' and click the following:

- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

Does this resolve the issue?

October 16, 2018 at 3:40 pm #2821652

dharmendraC

Sorry, I tried everything that you said. Still the same

October 16, 2018 at 5:34 pm #2822000

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

The topic ‘[Closed] Split:In english version the properties are not showing up.’ is closed to new replies.