This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 3 voices.

Last updated by Bigul 5 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
March 17, 2019 at 12:25 pm #3363339

thijsK-5

I am trying to: build a static front page in three different languages (English, Dutch and German)

Link to a page where the issue can be seen: hidden link

I expected to see: the layout of the widget area according to the number of widgets that should be visible for each language

Instead, I got: the layout as if there are more widgets that should actually be visible based for each language

The homepage is created using the built-in customiser for editing the front page widgets. Within these widgets I am using the dropdown to select for which languages the specific widget should display. This all seems to work fine up and until a specific amount of widgets. Front page widget areas 1 and 2 are working perfectly, but for front page widget area 3 (and others which are now temporarily using a workaround and display less content) I am running into the following issue:
- Front page widget area 3 is using four widgets per language, so 12 widgets in total.
- A widget area with four widgets should display as one full width widget in the first row, and then a second row with three 33% widgets.
- However, when I add four widgets for Dutch, four widgets for English, and four widgets for German, the entire widget area is displaying one full widget in the first row, then a second row with two 50% widgets, and then a third row with one full width widget.

Feedback from StudioPress:
Hi Thijs,

Thanks for reaching out to us!

In regards to the issue you're seeing, it looks like both widgets are being counted instead of just one. I would recommend reaching out to WPML for advice on this and let them know what is happening and that if you remove one of the widgets the styling is correct. It's possible that WPML should be filtering wp_get_sidebars_widgets() so the function only returns widgets for the active language, which would fix the incorrect count.

Could you please look into this?

Thanks,
Thijs

March 18, 2019 at 8:52 am #3366927

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Thijs,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

We are not able to access the site now. It shows *This site can’t be reached* error. Please check the attached image for more details. Therefore please share me a few screenshots for a better understanding of the issue.

Have you tried to translate the widgets? Please try with a widget and let me know your feedback. Check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/translating-widgets/

--
Thanks!

Bigul

March 21, 2019 at 10:06 am #3397847

thijsK-5

Hi Bigul,

Thanks for your support, and apologies for any inconvenience in regards to the unavailability of the site. it should be back online now, could you please check again?

Please note that we have temporarily introduced a workaround on the homepage for some widget areas, but the issue is still visible in the Services section of the homepage (please see attached screenshot). The widget is displaying one component on the first row, two components on the second row, and then another component on the third row - while it should in fact display one component on the first row and three components on the second row (please see second screenshot attached).

Do let me know in case you need anything else in this respect.

Thanks,
Thijs

March 21, 2019 at 5:39 pm #3415103

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Thijs,

Thank you for the updates. This may be a compatibility issue. Are these widgets are part of Altitude theme?

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

March 29, 2019 at 9:18 am #3489317

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Thijs,

Thank you for the login information. I am not able to replicate the issue exactly. The following layout configuration settings are missing for me.

hidden link

Please let me know the exact steps to replicate the issue. Sorry, I am using *Altitude Pro* theme for the first time.

--
Thanks!

Bigul

March 30, 2019 at 12:42 pm #3498371

thijsK-5

Hi Bigul,

There is no need to replicate the issue, because the issue already occurring on the live homepage. Please note that the widget area saying 'Services' should be displayed as number 4 in the layout configurations (hidden link). This can be verified by the fact that if you only have one language, the widget area is indeed displaying in layout configuration number 4 (two rows, with one and three columns respectively).

However, as you can see on the live homepage, the widget area is displayed differently (three rows, with one, two, and one columns respectively). Please note again the feedback from StudioPress:

I would recommend reaching out to WPML for advice on this and let them know what is happening and that if you remove one of the widgets the styling is correct. It's possible that WPML should be filtering wp_get_sidebars_widgets() so the function only returns widgets for the active language, which would fix the incorrect count.

Regards,
Thijs

April 1, 2019 at 11:12 am #3506799

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Bigul has a day off today, he will be back on the forum tomorrow and will take care of this ticket forward. I hope this is OK for you 🙂

Thanks

April 2, 2019 at 1:28 pm #3517637

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Thijs,

Thank you for the updates. Sorry, I am a bit confused about the Layout and Widgets of Homepage. Because we are new to *Altitude Pro* theme. Please check the attached images.

I am not able to find the widgets and widget settings exactly. So please share more details about this. It will be great if you can share a screencast for a better understanding.

--
Thanks!

Bigul

April 11, 2019 at 2:07 pm #3588677

thijsK-5

Hi Bigul,

To edit the homepage in Altitude Pro, please use the following steps:
1. In the WordPress Dashboard, select 'Appearance > Customise'
2. Navigate to 'Widgets'
3. Select ' Front page 3' to open the Services widget

All content is displayed using a Custom HTML widget. This widget is preconfigured to select for which language the widget should display (either a specific language or all languages). The issue is with how the widgets are displayed, as described above.

Hope this helps. Appreciate your support.

Regards,
Thijs

April 24, 2019 at 10:34 am #3671593

thijsK-5

-cut-

April 24, 2019 at 10:38 am #3671649

thijsK-5

Hi Bigul,

Thanks for your response. It looks like the install has expired. Having said this though, I can confirm that it was working before I installed WPML. This specific site used to be single language first. After installing WPML to make it multilingual, this issue appeared. Looks like we can confirm it is a compatibility issue, can you ask your compatibility team to look into it?

Thanks,
Thijs

April 24, 2019 at 5:44 pm #3675647

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Thijs,

Thank you for the feedback. The sandbox site will expire after a week if there is no activity in the site. Please check previous private message. I update the sandbox site details with the new one.

Can you please try to reproduce the issue in the fresh installation(new sandbox site). So we can troubleshoot the issue without affecting the live site.

--
Thanks!

Bigul

The topic ‘[Closed] Static front page counts widgets incorrectly’ is closed to new replies.