Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Itamar 9 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
February 15, 2019 at 9:37 pm #3206641

teresaG-7

I am trying to: complete translation

Link to a page where the issue can be seen: alla new traslatione

I expected to see: My translation works go to COMPLETE status

Instead, I got: nothing, always uncomplete status

February 17, 2019 at 8:45 pm #3209590

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Could you please let me have access to your site and explain to me where I can see this problem on your site?

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

February 18, 2019 at 8:51 am #3210563

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for the access details.

I've completed one of your translation without any problem.
For example, please see the 'Biocollagenina beauty drink formula lift' post.
All I needed to do was to check the 'Translation is complete' checkbox and then the 'Save and close' button. Please see the attached screenshot translation-is-complete.jpg.
Then I've checked the Translations queue, and I could see that the job is marked as 'Complete'. Please see the attached screenshot job-complete.jpg.

Can you complete the translations of the products this way?

Please review our documentation about WooCommerce Multilingual.
https://wpml.org/documentation/related-projects/woocommerce-multilingual/

Thanks,
Itamar.

February 18, 2019 at 8:59 am #3210612

teresaG-7

Thanks Itamar,
you can complete translation because now appear the classic translation editor, this is another problem, the Advanced translation editor are enabled but appear the classic translation editor, all are enabled in wpml panel but not work anymore. If Advanced translation editor work you can reproduce the problem "not complete" status. Thanks

February 19, 2019 at 10:48 am #3216159

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and sorry for the late response.

Thanks for further elaborating on the issue.

Could you please give me access as a user with administrator privileges so I can better check the problem?

I'm enabling a private message again.

Thanks,
Itamar.

February 19, 2019 at 12:09 pm #3216483

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Jana and thanks for the access details.

Since this is the same issue that you have already on another ticket with Alejandro, please close the other ticket and let's continue to handle this issue in this ticket. Please understand that there is no point to keep tow tickets with the same issue.

When I access the admin of your site, I want to change the admin language into English so it will be easier for me to navigate in the admin section. But I cannot access my profile. I get this message.
You don't have permission to access this page
A user should always be able to enter its profile. I'm saying that to point out that something is wrong and it is not related to WPML as far as I can tell now.

With the admin user that you gave me I've managed to appoint myself as a Translation Manager. And also to make myself a translator. Then I've created a test post and assigned it to myself. And I can see the issue. Although that the ATE is enabled for new jobs, I get the CTE when I try to translate the post.

Then I've realized that you are also using a plugin that is called 'User Role Editor'. And you have a user with the name 'Translator'. I suspect that this plugin might cause the issue that you have with the ATE.
Could you please deactivate this plugin and see if the issue persists?

If it does persits, then I would like to ask you to try a full minimum environment procedure in the following way. Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated but WPML. You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example).
If it persists then deactivate all plugins except WPML and its add-ons.
Then please check if the problem persists. If it does not persists so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

February 19, 2019 at 12:46 pm #3216568

teresaG-7

'User role editor' are used for "doctor" role, translator role are from wpml and are untouched.
I open new ticket because the old one are closed when I open this, now alejandro re open I Think.
The problem persist from two week, in first ticket Alejandro tell me to wait for new version of wpml, but new version don't solve and add a incompatibility whit other plugin, now this as solved but ATE problem remail. So now I don't have time to clone another time my website to check all 40 plugin for problem. I tell translator to use classic editor and leave ATE. Thanks

February 20, 2019 at 12:07 pm #3221513

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

OK, I see.

So I'm closing this ticket, and when Alejandro tells you the there is a new version with the fix and if needed continue on the ticket with Alejandro here.
https://wpml.org/it/forums/topic/dont-change-translation-status-after-clic-complete-button/

Best Regards,
Itamar.