This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Thomas 3 years, 6 months ago.

Assigned support staff: Thomas.

Author Posts
March 15, 2016 at 8:45 am #837920

marcH-8

Hi there, I have this problem:
I have two sites running wpml with different themes. Site 1 works just fine and when I update the original page (which is set to German for both sites), the other languages show the update button (round arrow, see screenshot). For site 2 there is NEVER this update arrow, but only the edit pens for the other languages.
See this screenshot: hidden link
it shows the other languages to be updated and that's fine, because I changed the original page/language.
Here is the screenshot of site 2 that never shows the update arrow:
hidden link
Any idea why this is so?
thanks, marc

March 15, 2016 at 2:39 pm #838355

Thomas

Hello and thank you for contacting WPML support!

This is because of this:

### Translate vs Duplicate content ###

## Translate ##

To create a translation of post manually, please refer: https://wpml.org/documentation/translating-your-contents/creating-translations-manually/

If you created a post in English and later translate that to Chinese, then any modification in English post will not affect the Chinese translation.

## Duplicate post ##

This feature is mainly used when you want to display the original language post in other language. For more information on duplication post, please refer "Duplicating Content from the Editor" section at: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-using-content-duplication/

If you created a post in English and later duplicate that to Chinese, then any modification in English post will be copied to Chinese translation.

If you created a post in English and later duplicate that to Chinese, if you made changes to Chinese duplicate post, those changes will get lost because Chinese post is duplicate of English and it will be always synchronized with English post.

If you later decide to translate this Chinese duplicates post yourself, click on the plus sign (+) icon to edit them. There, WPML shows you that they are duplicates. Click on the button to translate them individually and start editing.

For further information or if you have any questions related to this ticket please do not hesitate to contact us.

March 15, 2016 at 4:15 pm #838473

marcH-8

Hi Thomas,

the fact is that BOTH sites have the same setup and on both sites I always create the translated versions by duplicating the content, then changing it and then telling wpml that this page is maintained alone, not a duplicate content. So, on site 1 it works perfect, showing me the sync icon when I change the original, on page 2 it shows me the edit pencil only, never the sync icon. But both sites are identically (besides the theme) and when I create a new page, I do it the same way on both sites.

March 16, 2016 at 7:19 am #838859

Thomas

I see another problem with your server:

### PHP version ###

Finally increase PHP Version to 5.6.* and MySQL to 5.6.*

These values are also helpful:

.htaccess
php_value allow_url_fopen On

or

PHP.ini

allow_url_fopen = „On“

You may contact your hosting provider to make changes.

### Increase WP Memory Limit ###

I see your WP Memory Limit is only 40M. Can you please increase it to 128M to avoid any memory issues?

To do so please follow this guide:

http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

March 31, 2016 at 7:58 am #849700

marcH-8

Thomas, I have updated php + mysql to latest versions and raised the wp memory limit + allow_url_fopen. Still the same issue!

any idea? By the way, the php + mysql settings/versions are server-wide and as I said, I have this problem with one domain on the server, but with NOT with another domain on the same server!! So, I rather guess it's a theme problem with wpml.

thanks, marc

March 31, 2016 at 8:04 am #849705

Thomas

A new version of WPML plugins is finally released and I encourage you to update to Version 3.3.7

https://wpml.org/2016/03/wpml-3-3-7-released-wordpress-4-5-compatible-faster-stable/

### How to update ###

The most recent WPML versions can be seen here at https://wpml.org/account/downloads/ or in the WordPress dashboard if automatic updates are enabled.

Here's an article about how to manually update WPML plugins and register WPML to receive automatic updates:
https://wpml.org/faq/install-wpml/

### Thank you ###

Please give feedback in case your problem was not solved.

Thanks for your patience.

March 31, 2016 at 9:44 am #849828

marcH-8

I have the newest version! Still same problem.

March 31, 2016 at 11:44 am #850000

Thomas

Your problem is:

On one website you have chosen "translate page / post" function that's why you see the pen.
On the other website you might have chosen "duplicate page / post" that's why you see the circled arrow and are unable to translate manually.

Simply choose translate page where you can't see the pen:

https://wpml.org/documentation/translating-your-contents/creating-translations-manually/

March 31, 2016 at 12:40 pm #850124

marcH-8

Thomas, I am doing exactly the same on both sites!! This is what I do: I create a page in German and then I duplicate this page to English and Italian. When editing the English or Italian page, I am telling wpml that I translate it manually. This works fine on one site, but not on the other. Well, the reason might be that I had imported the pages with the wpml importer for the theme I have. Maybe in this way wpml doesn't know that the pages are duplicated. Is there a way to fix this? thanks.

March 31, 2016 at 12:58 pm #850148

Thomas

I totally got the point.

I think this documentation might help you. Really:

https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-using-content-duplication/

The topic ‘[Closed] status shows always the edit pen but never the update arrow’ is closed to new replies.