This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I would like my translated page URLs to look like this example: domain.ca/fr/your-liver. Instead, they look like this: domain.ca/fr/?page_id=13196

Solution: - Go to your Dashboard > Pages. - Open your page of interest. - Click on the language switcher and change to your secondary language. - Verify that your translation has the Published status.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by veronicaR-2 1 month, 2 weeks ago.

Assigned support staff: Andrés.

Author Posts
August 29, 2019 at 2:46 am #4477413

veronicaR-2

I would like my translated page URLs to look like this example: liver.ca/fr/your-liver

Instead, they look like this: liver.ca/fr/?page_id=13196

I have tried using Sticky Links, but it doesn't seem to have worked.

August 29, 2019 at 5:34 am #4477905

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

Our WPML Sticky Link plugin only converts your links target, it does not translate your URL's. For that reason, I don't think this plugin is involved and the problem may be in other place.

According to your URL format, it seems that this page has not been published yet, actually I can't access to it. Let's try the following:
- Go to your Dashboard > Pages.
- Open your page of interest.
- Click on the language switcher and change to your secondary language.
- Verify that your translation has the Published status.
Does it help?

Documentation:
https://wpml.org/documentation/getting-started-guide/sticky-links/

Best regards,
Andrés

August 29, 2019 at 11:28 am #4480495

veronicaR-2

Hi Andres,

This is what I see when I go to Dashboard > Pages > open this page. Is this dropdown on the right the language switcher you mentioned? When I click it, all I see as an option is English.

I did click the Update icon beside French and Chinese under the Translation header but that just brought me to the WPML editor.

Not sure how to see if a language page is set to Publish.

** EDIT: I changed my dashboard language to French, then went into my Pages, then saw that the French page was indeed a draft. I'll go and switch all drafts to Publish. Thank you!**

August 29, 2019 at 11:32 am #4480531

veronicaR-2

My issue is resolved now. Thank you!

August 29, 2019 at 11:32 am #4480533

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Great! 🙂
I'll be waiting for your results.

August 29, 2019 at 11:34 am #4480539

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Oh, I think we just crossed some replies and I re-opened your ticket. 😀
I'm glad to know that it is solved anyway.
Regards

August 29, 2019 at 10:08 pm #4483667

veronicaR-2

Thanks!