This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Bruno Kos 6 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
March 11, 2019 at 3:11 pm

Jan-Philipp Wittrin

I am trying to: Create a translation of a product. The stock level of the wc product is set to individual and fe. 10 pcs in stock.

Link to a page where the issue can be seen:

Original Product: hidden link
Faulty Translated Product: hidden link

I expected to see: The same stock level in the translated product than in the original product.

Instead, I got: An empty stock level field.

But, here is the weird thing: Once I created the translation and go back to the original product and change the stock level to another number and resave the original product the translation will be updated to the new stock level.

Debug Steps I already did:

- Deactivated any plugin which are not Woocommerce or WPML.
- Switched to Storefront Theme.
- Reproduced the issues on another website with a different host.
- Used both WC Translation Editor and regular editor
- Translated regularly and via duplication

All these steps bring me back to a faulty behaviour of WC Multilingual.

March 12, 2019 at 10:10 am #3320813

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

It seems like that this was reported by some other clients as well and has been escalated to our WCML developers team for fixing. However, as a workaround, can you try this (after you create translations)?

WooCommerce -> WooCommerce Multilingual -> Troubleshooting -> Sync product stock quantity and status ( synchronizing min stock between translations ) -> Start?

Regards,
Bruno Kos

March 13, 2019 at 10:40 am #3332109

Jan-Philipp Wittrin

Hi Bruno,

The workaround did work, but in the wrong direction. Now both german and translated product are buggy and show the error, OUCH! 🙁

(Now also faulty) Original Product: hidden link
(Already) faulty Translated Product: hidden link

When do expect that your delevoper have fixed this rather important issue?

The shop basically renders useless through this issue.

Regards,

Jan-Philipp

March 13, 2019 at 3:47 pm #3335915

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I've set this into your custom XML configuration (WPML -> Settings -> Custom XML configuration)

<wpml-config>
    <custom-fields>
        <custom-field action="copy">_stock</custom-field>
    </custom-fields>
</wpml-config>

And now it works, however, this is only a current workaround until this is fixed in future versions of WCML (it has a major priority in our internal bug tracking system so most likely it will ship within one of the next versions).

I will keep you posted on this.

Regards,
Bruno Kos

March 19, 2019 at 6:31 pm #3382607

Jan-Philipp Wittrin

Hi Bruno,

cool. Thank you for the quick fix.

Yes, it would be cool to be kept posted on this.

Regards,

Jan-Philipp

March 20, 2019 at 9:58 am #3387023

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Jan-Philipp,

Sure, I will update this ticket as soon as I get more information from developers, since this issue has been escalated there already and is labelled with a "major" priority.

Regards,
Bruno Kos

April 5, 2019 at 11:58 am #3543849

Ajanweb

Hello,

The same problem occurs for us.

Our default language is English with correct stock.
Our 2nd language is Turkish with old stock.

We synced the stocks using "Sync product stock quantity and status".

However it synced the Wrong way!
Instead of syncing from English (default) to Turkish (secondary) it went the wrong way. Now all English stocks are wrong too!

Is there a way to change the direction in options?
Or does this custom xml still work?

Thank you,

April 5, 2019 at 12:03 pm #3543867

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you update WooCommerce Multilingual to 4.5.0 and check now?

https://wpml.org/download/woocommerce-multilingual/?section=changelog

Regards,
Bruno Kos