This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Mihai Apetrei 6 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 4, 2019 at 8:48 am

Ajanweb

Hi,

The master language is set to English.

Turkish language stock shows lock. (so far so good.)

However, products in Turkish language cannot be added to cart, WPML thinks the stock is 0, where as the English stock is 7.

Products can only be added to cart from English language.

WPML version is: 4.1.3
Woocommerce version is: 3.5.3
WordPress version is: 4.9.8
Theme: Royal

Unfortunately, this is effecting ALL of our WPML sites.

In bagohandicrafts.com we have the same issue.
WPML: 4.2.4.1
Woocommerce: 3.5.3
WordPress: 5.0.4
Theme: The Hanger

At the moment, all sales have stopped. So it is an urgent issue. People were opening tickets saying that quick edit does this, but for bagohandicrafts.com quick edit is not being used. Even updating the master language (going to the product, making sure stock is > 1, hitting update) is not solving it.

We can provide admins to the sites if requested.

Thank you,
ajanweb

April 4, 2019 at 11:36 am #3534407

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see here (hidden link), you are using older versions of our plugins (attached screenshot).

Also, if I try to go to WPML > Support, I get a 500 error (attached screenshot).

1. Please create a full backup of the site and then go to the link above and update all the plugins to the latest version.

2. After this, regarding the stock issue, please follow the steps here:
https://wpml.org/forums/topic/stock-is-not-synchronizing-between-languages/#post-1566643

3. If after you follow those steps, things don't get solved, please do this:

- disable all plugins except WPML plugins and WooCommerce
- check if the issue is happening again and even try to do the same steps from point 2 above once again
- if it's not happening anymore, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 4, 2019 at 4:06 pm #3536865

Ajanweb

Hi,

We'll go ahead and do that, but the same problem occurs in

bagohandicrafts.com
WPML: 4.2.4.1
Woocommerce: 3.5.3
WordPress: 5.0.4
Theme: The Hanger

This uses relatively new versions.
Are you sure it's version / plugin related?

(We'll report back with our findings.)

Thank you.

April 4, 2019 at 4:32 pm #3536981

Ajanweb

Shall we give you an admin for bagohandicrafts.com as well? If so how can we relay that without opening a duplicate ticket? I just want to show that this issue is effecting all our sites. Bago uses a completely different theme and is up to date as shared above.

April 5, 2019 at 11:39 am #3543745

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

After you update the plugins to the latest version (step 1) and then go through the stock-sync process (step 2), the stock should be synced.

We can't know for sure that the version of the plugins is what is causing this issue, but we have to make sure that plugins are always updated to the latest version before we go deeper with the debugging process. However, I hope that the stock-sync process from step 2 will solve this issue and you won't need to go forward to step 3.

However, if the first 2 points don't solve the issue, step 3 should help us understand better what is actually causing the issue and it might give us some important insights.

Please do not forget to first create a full backup of the site and then get back to me and let me know if anything changed after following the steps.

I am also enabling the private fields below this post so that you can send the other site credentials so that I can take a look but usually for each issue we need to have a new ticket created so if the solution we will find in this ticket won't solve the issue on the other site, I will need you to create a new ticket for that issue.

Hopefully, we will be able to find the solution that will solve the issue on both the sites.

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Just a note that I won't be working on the weekend, so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

April 15, 2019 at 10:01 am #3611953

Ajanweb

Hi,

Indeed the stock not updating between languages was a version issue. Updating everything to the latest versions solved the problem.

HOWEVER, the stock sync (in WPML settings) still syncs the stock in the wrong direction. Having an option to specify direction would be extremely helpful as a feature.

Here's how we solved that.
We selected all products in the English language. We selected quick edit. We added a tag. We hit update. All stocks were synced.

Thank you.

April 15, 2019 at 10:15 am #3612315

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi!

I am very happy to hear that the issue got solved and thank you for sharing the steps you took.

Regarding your recommendation, that sounds great and I strongly recommend you to take just a few minutes and add it to our feature-request form page here:
https://wpml.org/suggest-a-new-feature-for-wpml/

Also, can you please mark this ticket as resolved?

Thank you! 🙂

Kind regards,
Mihai