If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: for some products stock does not synchronize to second language.

Solution: Please follow this steps: - Create a full backup of the database. - Update all outdated plugins and themes. - Flush any cache memory that might exists. - Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Select all options and click on the 'Start' button.

Relevant Documentation:

This topic contains 3 replies, has 2 voices.

Last updated by Carlos Rojas 4 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 10, 2019 at 9:10 am #4177583

matijaP

Hi,

for some products stock does not synchronize to second language.

For this product in english stock at all variations show 0. hidden link

In second language still show some stock: hidden link

This is just one product we have issue with. Can you help me to fix it?

July 10, 2019 at 9:49 am #4177885

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Please follow this steps:
- Create a full backup of the database.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Select all options and click on the 'Start' button.

Could confirm that the issue is solved?

Kind regards,
Carlos

July 12, 2019 at 8:22 am #4196281

matijaP

My issue is resolved now. Thank you!

Should this be preformed every while or synchronization should be done automatically?

July 12, 2019 at 11:08 am #4197969

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I'm glad to hear that the issue is solved 🙂

Synchronization should be done automatically, however see you see the issue happening again you can try the troubleshooting steps.

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos