This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 2 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
July 26, 2019 at 10:28 am #4289113

matijaP

Stock synhrtonization between languagesdoes not work like it should. When i manually set it over troubleshooting is fine but next day i again get same issue:

Sync product stock quantity and status ( synchronizing min stock between translations ) 1336 left
Fix translated variations relationships 2376 left

How i can pernamently fix this issue?

July 26, 2019 at 3:44 pm #4290697

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Does it happens with all types of products? Please try the following troubleshooting steps after a full site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

4) Visit WooCommerce>>WooCommerce Multilingual>>Status>>Troubleshooting

5) Try the WooCommerce Multilingual Troubleshooting steps again

--
Thanks!

Bigul

August 1, 2019 at 7:07 am #4319165

matijaP

Hi Bigul,

i did all this but after i refresh my webiste and still shows:
Sync product stock quantity and status ( synchronizing min stock between translations ) 1342 left
Fix translated variations relationships 2376 left

August 1, 2019 at 5:38 pm #4324569

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please deactivate WooCommerce Multilingual for a moment and check is there any difference in the result.

Please share with me the WordPress debug.log (not WPML debug information) for more details.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

The topic ‘[Closed] Stock synchronization between languages’ is closed to new replies.