This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 26, 2018 at 9:41 am #2766660

maxS-16

Hi,
we have the problem, that the language selector does not work anymore because of strange redirects. This is a hosted instance, so no special server/htaccess config.

For example /?lang=de gets redirected (HTTP 301) to /?lang=de%2F%3Flang%3Dde, which is not recognized as valid language.

Also, every subsite is redirected to a completely wrong url, for example /team/?lang=de gets redirected to /?lang=de%2Fteam%2F%3Flang%3Dde which ends up at the EN index page, no matter which language I choose.

If i disable WPML Core this does not happen, also if I set the url schema to /<lang>/<pagename> it gets me to https:/DOMAIN. eu/en//en//en//en//en//en//en//en//en//en//en//en//en//en//en//en//en//en//en//en//.

Is there any way to debug this?

September 27, 2018 at 5:11 pm #2771342

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

I used the redirect checker at hidden link to check for redirects, and I see that hidden link is 301 redirected to hidden link

If you did not manually set this, perhaps it is coming from another plugin or theme? To test this, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, is the issue resolved?

October 2, 2018 at 8:06 am #2780648

maxS-16

Hi, thanks for your reply. Updating all plugins including WPML and disabling all plugins one after the other were the first things we did. The redirects only stopped after disabling WPML core.

October 2, 2018 at 2:40 pm #2781908

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

October 4, 2018 at 9:38 pm #2788835

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending the files. I was able to download them but I can't run the installer because the password you sent is not working. See attached screenshot. I tried all passwords that you provided and none worked. Can you please double check and edit your previous reply as needed? Thanks!

The topic ‘[Closed] Strange 301 redirects’ is closed to new replies.