This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: After installing WPML the WooCommerce Products page layout is messed up in the backend.

Solution: Solution here: https://wpml.org/forums/topic/strange-error-woocommerce-products-background/#post-3985633

Tagged: 

This topic contains 13 replies, has 3 voices.

Last updated by yao-yuT 4 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
May 25, 2019 at 2:39 pm #3889557

kellyP-7

Hi I got some problems over here.
You will see whats wrong in my print screens. ( see SEO title ) on the overview product pages in the background.

After installing the WPML plugin.

Tryed several times but it seems to be a problem with the WPML plugin.

Can someone help me please?

Thank you so much

May 26, 2019 at 11:19 am #3891591

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. We have another client who had the similar issue and was also able to solve it, this may help in your case (Summary at top):
https://wpml.org/forums/topic/wpml-translation-messes-up-the-woocommerce-products-page/

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

May 27, 2019 at 11:18 am #3896431

kellyP-7

Hi,

Thanks for your reply. I tried to fix it by using the tips i got from the other topic. but i cant change the screen options. i can only change one feauture (see image).

i understand that the problem is caused by the yoast plugin in combination with WPML.

Thanks.

May 27, 2019 at 12:15 pm #3897009

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have checked screen options in my localhost with fresh installation and ‘Columns’ section is there as you can see in the attached screenshot but it’s missing in your screenshot.

Could you please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and Yoast SEO and see if this issue goes away with default theme and only WPML activated?

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

May 30, 2019 at 8:02 pm #3925993

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

WP login info that you have provided is not working here. Could you please provide me working login please. I have enabled private input box for your next reply.

Thank you

June 3, 2019 at 7:54 pm #3945717

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Wp login info still not working here as you can see in the attached screenshot. Could you please provide me working login please.

Thank you

June 7, 2019 at 7:44 pm #3978877

kellyP-7

That is so strange, can you give me an email adress so you can set your own password?
Thanks,

June 9, 2019 at 9:26 am #3982613

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Here is my email: [removed]

Thank you

June 9, 2019 at 2:45 pm #3983173

kellyP-7

Hi, I send you an email so you can set up your own password.
Your login name will be: wpmlnoman.

I had to change my password for the FTP for security reasons, if you need the new one please ask.

Thanks for helping

June 9, 2019 at 3:56 pm #3983295

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for login details. I have hidden ‘Yoast SEO Meta Box’ from SEO >> Search Appearance >> Content Types > Products as you can see in the attached screenshot and now products columns looks fine.

You can show/hide ‘Yoast SEO Meta Box’ from there if needed.

Please let me know if this resolves your issue or you need further assistance.

Thank you

June 9, 2019 at 5:06 pm #3983501

kellyP-7

Hi Noman,

Thanks for this quick response. I see the problem is solved now but when i go to one product the yoast plugin cant be used there. For now i can only change meta discriptions on my other pages exept the product pages.

i need to use the tool for every page offcourse. im sorry

Thanks

June 10, 2019 at 7:35 am #3985633

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- I have enabled ‘Yoast SEO Meta Box’ from SEO >> Search Appearance >> Content Types > Products.
- Installed File Manager plugin to add below code in your child theme functions.php file:

add_action('admin_head', 'add_admin_css');
function add_admin_css() {
echo '<style>
  .post-type-product div.wrap {overflow-x:scroll; width:98%;}
  .post-type-product table.wp-list-table.fixed{table-layout:auto;}

  .post-type-product table.wp-list-table th#title{min-width:350px;}
  .post-type-product table.wp-list-table th#categories{min-width:150px;}
      
  </style>';
} 

And now columns looks fine.

Please let me know if this resolves your issue or you need further assistance.

Thank you

June 13, 2019 at 11:00 am #4012161

kellyP-7

Hi Noman,

Thanks for your help. you resolved the problem really well. Your a hero!
Thank you so much!

October 10, 2019 at 12:13 pm #4730083

yao-yuT

The bug is well fixed, thank you for ur great help!