This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Jamal 5 months, 4 weeks ago.

Assigned support staff: Jamal.

Author Posts
February 21, 2019 at 9:21 am #3225992

chielv-2

Hi all,

For my site hidden link i am using WPML.
If you select other language (english flag) the url string will be: .nl/?xdomain_data=CNWjdDGqSgzDLZg7MR5QlcEBgh3u1kpUWgKAaLsvV9g6uNWr9WrJ5hwZcnU%3D

I want to redirect it to .com

I already got domain alias in Plesk

Anyone know what i am doing wrong?

Chiel

February 21, 2019 at 4:41 pm #3228875

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Chiel,

Thank you for contacting WPML Support. I will be glad to help with this.

Have you followed our article on the subject
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Have you been able to update your apache or nginx configuration ?
Can you please paste your WPML Debug information in the Debug information field?
- http://wpml.org/faq/provide-debug-information-faster-support/

Best regards,
Jamal
WPML Support

February 22, 2019 at 6:24 pm #3233666

chielv-2

Hi Jamal,

Here is my debug info.
I have try everything but dont know what to do anymore. Can you look with me with teamviewer please?

Chiel

February 25, 2019 at 9:43 am #3238734

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Chiel,

Sorry, we do not use TeamViewer in our support tools. After i checked your debug informations i would like to ask you the following.
Increase WP Memory limit
Increase WP Memory limit to at least 128M to conform with our minimum requirements https://wpml.org/home/minimum-requirements/

Specifically, could you set WP Memory limit to 256MB?
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

If unsure on how to set this, you can consult your host/server admin to do this. After you increase this value, you can confirm it by checking on WPML->Support by finding the “Memory limit” value.

Update WPML plugins
Please update WPML plugins to latest release, so we do not investigate an already resolved issue.
- Go to Dashboard -> Updates
- Press the "Check Again" button
- Press the "Update" button at the bottom of the page
- Try to update the plugins

- Go to Plugins -> Add New -> Commercial
- Press the "Check for updates" button
- Try to update the plugins

- Go to https://wpml.org/account/sites/ look for your current key and erase it.
- Create a new one for your site.
- Go to Plugins -> Add New -> Commercial
- Click on the "Unregister WPML from this site" button
- Register WPML adding your new key.
- Try also disabling the "Keep wpml.org up-to-date about which theme and plugins I use" option

If that does not work, you will need to manually update the plugins.

❌ Before proceeding please make a full website backup! ❌
- Download the latest version of WPML from https://wpml.org/account/downloads/
- Disable WPML Multilingual CMS
- Delete WPML Multilingual CMS (the settings and the translations are saved in the database so they will not be deleted)
- Upload the freshly downloaded WPML plugin from Plugins -> Add New -> Upload Plugin
- Activate WPML
https://wpml.org/faq/install-wpml/

PHP debugging
Activate PHP debugging to reveal any errors that might be the cause of this issue.
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Share the debug.log (log file inside the /wp-content/ directory) here or using DropBox or GoogleDrive.

Best regards,
Jamal
WPML Support

The topic ‘[Closed] Strange url string after selecting other language per domain’ is closed to new replies.