Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 2 voices.

Last updated by Mihai Apetrei 8 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
January 28, 2019 at 11:25 am #3135120

marnixv-2

I am trying to: View a WooCommerce product page

Link to a page where the issue can be seen: hidden link

I expected to see: only the product information

Instead, I got: the product information but also lots of scrolling white blank.

January 28, 2019 at 11:38 am #3135230

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I can see (I attached a screenshot, too), the extra space is found in the "wc-tabs" (WooCommerce tabs) section.

Please follow the next steps:

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. If the issue still persists, we will need to check for a possible theme or plugin conflict.

- disable all plugins except WPML, WPML add-ons and WooCommerce
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML/WooCommerce plugins disabled:

- leave all the non-WPML/WooCommerce plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Also, do you have any other idea why that might happen? Did this happen after you took a specific action on the site (eg. updating plugins/themes/WordPress version)?

I will be waiting for your response.

Kind regards,
Mihai Apetrei

February 6, 2019 at 2:22 pm #3166117

marnixv-2

Hello Mihai,

thank you for the quick response.

Steps I took:
-Updated the skin to the latest version
-Updated PHP to version 7.2+
-Put momory limit up to 256
-Put some extra code in the htaccess to load the website faster

But the issue still exist, so I disabled all. And put plugins on and off. The problem turns up by one plugin: "WooCommerce Multilingual" it's the latets version. The question is, do I need this plugin because I have just one currencie.

Looking forward for your reply,

Marnix //

February 7, 2019 at 3:40 pm #3171108

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

The "WooCommerce Multilingual" WPML add-on makes your WooCommerce life easier, allowing you to easily translate multiple things so I would not recommend disabling it. There's for sure some incompatibility in the middle that's causing that.

1. Do you know if you are using a specific plugin that you are creating those tabs with?

2. Also, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai

February 11, 2019 at 11:04 am #3182372

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

Yes, those are the tabs I was referring to.

I was testing your site and I am not able to see the spaces anymore (I am attaching 2 screenshots, one for each language).

Have you resolved this or it still shows to you?

If they still show to you, can you please confirm once again that this (hidden link) is the link where the tabs look bad? Also, can you please let me know if you are using a different browser than Google Chrome?

I will be waiting for your response.

Kind regards,
Mihai

February 11, 2019 at 11:12 am #3182428

marnixv-2

Hello Mihai,

The test page is still hidden link
Because I deactivated the plugin WooCommerce Multilingual the page looks nice.

At this moment I activated that plugin so you can see it goes some where wrong.

Looking forward,

Marnix

February 12, 2019 at 7:09 am #3186762

marnixv-2

Extra info: I can't update 2 of the WPML plugins, I've got an error: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

Also there is a problem in using the PowerPress plugin, I can't add a MP3 File. Also an error: powerpress > Error occurred downloading media file.

I know, one issue at a time. Please help.

Marnix

February 12, 2019 at 8:17 am #3187057

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi Marnix.

Regarding this: "Extra info: I can't update 2 of the WPML plugins, I've got an error: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature":

This is a known issue and we are working on a fix. For now, please use the workaround our colleague, Vincenzo, added in this ticket: https://wpml.org/forums/topic/error-when-trying-to-update/

Regarding this: "Also there is a problem in using the PowerPress plugin, I can't add a MP3 File. Also an error: powerpress > Error occurred downloading media file.":

From my understanding, there is also a different issue happening.

In our forum, we try to keep one issue per ticket.


Continuing with one ticket per issue helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.

While I work on debugging the main issue here, may I kindly ask you to please open a new ticket for the additional issue?

Also, it would be very helpful if you could provide more information in the ticket like the exact steps you took to make the issue take place, screenshots, and links.

This will help us in our debugging process.

I will keep you updated with any new information regarding the original issue.

Kind regards,
Mihai

February 12, 2019 at 8:53 am #3187312

marnixv-2

Clear message!
Hereby the screenshots for the main issue.

Marnix

February 12, 2019 at 8:58 pm #3190895

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi.

When I said this "Also, it would be very helpful if you could provide more information in the ticket like the exact steps you took to make the issue take place, screenshots, and links." I was referring to do that on the new issue that you are experiencing, in the new ticket that you will create.

Regarding the main issue, it looks like this is a compatibility issue but we will be able to know for sure if that's the case depending on the result we will get by following the next compatibility-check steps below.

I created this environment for you here (one-click login):
hidden link

Feel free to set up WPML+WooCommerce (they are already installed in the environment above) and just install the plugin that you use for adding those tabs and after that set it up and try to recreate the issue.

Please let me know when that's done so that I can take a look, too.

I'm looking forward to your answer.

Kind regards,
Mihai

February 13, 2019 at 12:10 pm #3193790

marnixv-2

Dear Mihai,

The issue is there, so there is no conflict with the template I use.
I hope you'll find the conflict.

See the attached images.

Marnix //

February 15, 2019 at 11:29 am #3204389

marnixv-2

Hello, extra information.

Also when I disable all the WPML plugins the problem is there. Only when I disable WooCommerce Multilingual plugin the page is ok.

What do you think?! Looking forward to tackle this problem.

Marnix

February 15, 2019 at 1:33 pm #3205120

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi Marnix.

I was running a few tests but I need a few more things going forward.

1. I created the staging site just so that we can avoid working on the live environment. If you prefer me to work on the live site, I would be happy to do that as long as there is a backup done for it. Can you please confirm this is ok for you? Or if you have any staging/dev version/duplication of your current site, I would be happy to use that.

2. Please create a full backup of the site (files and database) and then update the plugins here:
hidden link

This might solve the issue.

After that is done, please let me know so that I can continue the troubleshooting process.

Just a note that I won't be able to respond in the weekend so if you confirm this is ok for you, I will be able to get back to you in the first 2 days of the next week.

Looking forward to your response.

Kind regards,
Mihai

February 19, 2019 at 10:50 am #3216180

marnixv-2

G'day Mihal,

I followed the steps by your collegue Radu, https://wpml.org/forums/topic/cant-update-wpml-updates/#post-3175708 and now I could updated the two WPML plugins.

Is there a way to update Advanced Custom Fields PRO? Because there is no update package. Is this plugin linked to WPML?

1. After updateing the WPML plugins the visual error is still there
2. You have permission to work in the live site. I made a back-up.

Regards,

Marnix //

February 19, 2019 at 5:27 pm #3218321

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for the updates.

I'm happy to hear that you were able to update the WPML plugins.

I will spend some more time on it, now that we are on the latest versions.

I will keep you up to date.

PS: Regarding the other question you had, Advanced Custom Fields is not part of our plugins. It is made by another company and I think that you should be able to get the latest version from their site (hidden link) if you bought the plugin.

Kind regards,
Mihai