Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I am trying to translate the following two strings, but they don't appear in String translation: https://snag.gy/O16B4X.jpg

Solution:
In most cases a string is not fully enabled and this is due to too many options being saved at once on that page. To fix this issue, please increase MaxInputVars to 10000 or more. For this, please try to set this variable in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

After increasing max_input_vars value you need to tick all the required strings from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> and click on “Apply” button.

Then please go to WPML >> String Translation and you will see newly enabled values at top of the page and ready for translation, add the translation for those strings and check Translation is complete checkbox and press Save button.

This topic contains 2 replies, has 2 voices.

Last updated by ka-chuS 5 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
June 18, 2019 at 2:21 am #4039397

ka-chuS

I am trying to:
Add the following two strings
hidden link

Result:
It said the "Data saved" as hidden link
However, the string is actually not saved and can't be found in the "string translation" screen.

June 18, 2019 at 5:53 am #4040567

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support. In most cases a string is not fully enabled and this is due to too many options being saved at once on that page. To fix this issue, please increase MaxInputVars to 10000 or more. For this, please try to set this variable in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

After increasing max_input_vars value you need to tick all the required strings from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> and click on “Apply” button.

Then please go to WPML >> String Translation and you will see newly enabled values at top of the page and ready for translation, add the translation for those strings and check Translation is complete checkbox and press Save button.

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

June 18, 2019 at 1:14 pm #4043971

ka-chuS

My issue is resolved now. Thank you!