Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: When the Look for strings option in turned off, the strings are in English and not in Latvian (site default language).

Solution: It seems that the original translations of Woocommerce (po/mo files) were overwriting the translations of String Translator. These steps solved the problem for our 2nd tier specialist:

- Go to WPML -> String Translator and search for the string with the issue (I tested with "Search results: “%s") - Delete the string - Go to WPML -> Theme and plugin localization -> String in the plugins and scan the "Woocommerce" plugin - Go to String Translator and translate the string again

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 11 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 28, 2020 at 1:32 pm #6470129

dmitrijsH

I am trying to: Have the product search properly translated.

Instead: When the Look for strings option in turned off, the strings are in English and not in Latvian (site default language). Please see the screenshots. At the same time, the Estonian page is correct. However, when I try to search for this string (using the Estonian words and "include translations" clicked on), I could not find it in strings translation.

product search strings.png
June 30, 2020 at 11:31 am #6485597

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
Thank you for contacting WPML support.

I kindly ask you to follow these steps:
- Create a full backup of the site
- Go to WPML -> Theme and plugins localization -> Scan the theme and the plugins related to Woocommerce
- Go to WPML -> Language -> Activate the Ajax cookie option
- Go to WPML -> String Translation -> Search and translate the strings. You may need to look into the Admin Texts section by following the steps described in this link: https://wpml.org/documentation/getting-started-guide/theme-localization/translating-options-coming-from-themes-and-plugins/

Could you tell me if the issue persists after the steps above?

Kind regards,
Carlos

June 30, 2020 at 1:05 pm #6486323

dmitrijsH

Hello,

All these steps have been done before I opened the topic, including the AJAX option. I cannot see anything relevant in the admin screen texts.

I can give you an access to a duplication of this website. It is a bit older (not so updated) but the issue appears both there and on the production website.

Thank you,

July 1, 2020 at 8:40 am #6492489

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
Thank you very much for your message.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to back-up the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

July 1, 2020 at 1:08 pm #6495879

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
Thank you very much for sharing this information.

I was able to reproduce the issue and after running several troubleshooting steps the issue persisted. For this reason, I decided to escalate this ticket to our 2nd tier of support where our specialists will take a deeper look at this problem and will try to isolate its cause.

I will get back to you as soon as I get an answer from our specialists.

Regards,
Carlos

July 3, 2020 at 11:27 am #6513711

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

It seems that the original translations of Woocommerce (po/mo files) were overwriting the translations of String Translator. These steps solved the problem for our 2nd tier specialist:

- Go to WPML -> String Translator and search for the string with the issue (I tested with "Search results: “%s")
- Delete the string
- Go to WPML -> Theme and plugin localization -> String in the plugins and scan the "Woocommerce" plugin
- Go to String Translator and translate the string again

Could you confirm that the issue is solved after following the steps above?

Regards,
Carlos

July 3, 2020 at 12:07 pm #6514035

dmitrijsH

My issue is resolved now. Thank you!

However, could you please confirm that in the future I can safely remove these problematic lines from the String Translation. Will they be readded after I rescan the plugin?

July 3, 2020 at 12:18 pm #6514179

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,
I'm glad to hear that the issue is solved 🙂

Yes, the strings will be read after scanning the plugin again.

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos