This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Andreas W. 3 weeks, 1 day ago.

Assigned support staff: Andreas W..

Author Posts
August 19, 2019 at 6:11 pm #4418201

andrewW-27

Hi, I cannot translate the woocommerce points & rewards plugin.....The default Product / Cart / Checkout message is not translated..

Shall I know I can fix this ?

Attached please find the screen for your reference.

Thanks & Regards,
Andrew

August 20, 2019 at 2:51 am #4420137

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

August 20, 2019 at 4:57 pm #4425567

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the access to you site.

I realized that you translated a string on String Translation but it is not showing up on Front-End. I then located the strings at String Translation -> Translate text in admin screens but somehow they are not able to be added to String Translation.

Also applying a Custom XML Configuration for those strings at WPML -> Settings -> Custom XML Config did not bring a solution, evenn when disabling any additional plugin.

I would kindly like to ask you to install the WooCommerce Points & Rewards Plugin on the following test site for further investigation:

One Click Login: hidden link

Leave me a short notification once the plugin is installed.

Kind regards
Andreas

August 21, 2019 at 10:22 am #4430033

andrewW-27

Hi, the plugin has been installed and being actived.

Kindly check.

Thanks & Regards,
Andrew

August 22, 2019 at 4:09 am #4436227

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would kindly like to ask you for your assistance.

I have created a store and a product in two languages. I have made the setup for the Points & Rewards Plugin and translated the notification strings with String Translation.

I made a test purchase and not any points been credited, neither I have seen any changes on the product page, cart or checkout.

Could you please have a look at the setup and let me know what I have missed?

One Click Login: hidden link

Documentation:
https://docs.woocommerce.com/document/woocommerce-points-and-rewards/

Kind regards
Andreas

August 22, 2019 at 3:07 pm #4440703

andrewW-27

Hi, I tested and I think it should be related to Sandbox credentials...It seems you Sandbox enviornment will make the plugin not worked.

Please check.

Thanks & Regards,
Andrew

August 22, 2019 at 6:41 pm #4442283

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please try again with this admin account:

hidden link

User: wpml
Password: support

Let me know about the outcome.

Kind regards
Andreas

August 23, 2019 at 2:02 am #4443339

andrewW-27

Hi, I have tried and still not worked....
I prefer you use a official wordpress site rather than sandbox to have a test...

Thanks & Regards,
Andrew

August 23, 2019 at 4:46 pm #4448885

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am leaving you a notification about that I have just sent you a private message on this ticket.

The message includes access to a test server install. Please make sure to add all necessary plugins and verify if the same issue persists on this new install of WordPress.

Let me know about the outcome.

Kind regards
Andreas

August 23, 2019 at 5:54 pm #4449243

andrewW-27

Hi, I have installed the plugins and test. The plugin is works now. Kindly check.

August 24, 2019 at 12:13 am #4450025

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The strings Points & Rewards were translatable on the test site after adding them from the section "translate texts in admin screens" on String Translation.

Now, I realized that I cannotadd any string from admin texts on your site, no matter from which plugin they are coming and even if I switch to a default theme or disable any additional plugins.

The issue might be related to a PHP setting. Proceed as followed:

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

MAXINPUTVARS

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1000. I would recommend you to change this setting to at least 3000.
You can find the php.ini file on your server inside the folder for your currently used PHP version 7.3.7.

In doubt please ask assistance from your host provider.

Once the settings are made got to String Translation -> Translate strings in admin texts and mark the matching strings. Let me know if this solved the issue or at least notify me once the settings have been done, and I will check the issue again.

Kind regards
Andreas

August 24, 2019 at 10:30 am #4451401

andrewW-27

Hi, I have followed your instruction, but the issue is not fixed.

August 24, 2019 at 5:04 pm #4452101

andrewW-27

Hi, finally, we have fixed the issue.

In php ini, we finally need the following edit:
max_input_vars:
10000
suhosin.post.max_vars:
10000
suhosin.request.max_vars:
10000

August 26, 2019 at 2:25 pm #4459709

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The wp-admin of your site currently ends in a 500 error.

Please have a look into our FAQ and take further steps:
https://wpml.org/faq/500-error/

Further, the provided FTP access leads to a directory which does not include WordPress. Did you migrate the site lately?

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

The topic ‘[Closed] string not translated (Woocommerce points & Rewards)’ is closed to new replies.