This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by miguelG-14 2 weeks, 6 days ago.

Assigned support staff: Laura.

Author Posts
September 18, 2019 at 8:29 am #4593733

miguelG-14

I am trying to: Translate a toolset content page with shortcode

[wpml-string context="Cursos" name="Proximo curso"]Próximo curso[/wpml-string]

Link to a page where the issue can be seen:

hidden link

I expected to see: Text in shortcodes translated

Instead, I got: Text in original language

-----

This translations were working fine !!! they stopped working after update

September 18, 2019 at 8:57 am #4593985

miguelG-14

Hi Laura
Not at all, they are in a Toolset custom page...

September 18, 2019 at 9:03 am #4594093

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I would ask then to try a compatibility test, if possible:
- backup your site
- disable all plugin except WPML and its addons, Types and Views
- switch to a default theme like TwentySeventeen
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again
- lastly, reactivate your theme

September 18, 2019 at 9:27 am #4594351

miguelG-14

Laura

That din't work... short codes are still not working

September 18, 2019 at 1:05 pm #4597001

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for trying.

Could you see if you can reproduce the issue here? hidden link

Just configure WPML and install Types and Views. You don't need to reproduce all the custom field, just one or 2 will be fine as long as we can see the issue.

September 18, 2019 at 7:07 pm #4599675

miguelG-14

Hi Laura

There is not issue on the sandbox ==> works well

Anything I can try to repair it on my installation?

Everything works well except for the string in short codes 🙁

September 20, 2019 at 4:23 am #4609741

miguelG-14

Hi Laura

The copy of the site is online... Thank you

September 23, 2019 at 12:22 pm #4623695

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I did some tests and it seems that with WPML 4.3.beta the issue is solved.

Check for example here: hidden link
Can you confirm?

If is that so, the issue will be solved in the next version.
However, we consider the beta stable enough to be used on production sites, but it's necessary to take some precautions. If you decide to test it, please do a backup before installing and report any issue you might have.

Please let me know if we can consider the issue as solved or if you want me to inform when the next stable version comes out.

September 24, 2019 at 5:14 pm #4633181

miguelG-14

My issue is resolved now. Thank you!