This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Nickolas 3 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 4, 2019 at 4:30 pm #4145421

Nickolas

Greetings!

I am trying to:
Fix some translation issues.

Link to a page where the issue can be seen:
The French homepage on hidden link

I expected to see:
Right below the slider, you can see a few products. The title above it is "Explore our products & services". It should be displaying the translated French string "Découvrez nos produits et services"

Instead, I got:
Well it shows the English string "Explore our products & services".
Same for the "Get a quote" button that should show in French, or the "Achievements" title and button right below the Quote call to action.

July 4, 2019 at 5:59 pm #4145735

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 9, 2019 at 5:34 pm #4173487

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I tried to access your website with the provided details, but your website seems to require additional steps for login, when trying these details I got this message: "VERIFICATION REQUIRED: Additional verification is required for login. Please check the email address associated with the account for a verification link". Can you review it please? A private reply is enabled for you again, thank you for your collaboration, have a nice day.

July 9, 2019 at 6:03 pm #4173653

Nickolas

Greetings

I was able to login without any issues with the account I provided but my IP is whitelisted so it could be that...
I think it's the reCaptcha that might causes issue there. Or Worfence Firewall...

Could you provide me the IP adress you are login in from so I can whitelist it?

July 9, 2019 at 11:29 pm #4174767

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above, thanks.

July 9, 2019 at 11:53 pm #4174769

Nickolas

I added the IP to the whitelist.

July 10, 2019 at 8:23 pm #4184281

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. I took a detailed in your website and could fix your issue with the steps below:

1 - In your WordPress Dashboard > WPML > Themes and plugins locations > Localization settings I clicked the option 'Assume that the original language of all strings is English'.

2 - Now in your WordPress Dashboard > WPML > Support > Troubleshooting I cliked these buttons:

2.1 - Clear WPML Cache
2.2 - Set language information
2.3 - Recreate ST DB cache tables

Please, let me know if you need any other detail. Have a nice day.

July 10, 2019 at 8:34 pm #4184287

Nickolas

I will let the client know about it.
Thanks for the support! Have a good day!

July 10, 2019 at 8:36 pm #4184297

Nickolas

My issue is resolved now. Thank you!