This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Laura 4 months ago.

Assigned support staff: Laura.

Author Posts
June 7, 2019 at 11:31 am #3975905

nenadM-4

I am trying to: String translate and I do it in trnaslate manager but anr fornt end itis not working

Link to a page where the issue can be seen: hidden link

I expected to see: Translated in english

Instead, I got: But it is still in serbian

June 7, 2019 at 1:01 pm #3976629

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

You said you used Translation Manager, but you can't use it to translate that kind of stuff. It should be in String Translation. What was your process exactly? Can you send me a screenshot of the strings from the backend?

June 7, 2019 at 1:43 pm #3976871

nenadM-4

yes I can, here they are:

June 7, 2019 at 1:57 pm #3976953

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

why do you have 2 different strings for "Year"? There might be a conflict between them and this would explain why it's not showing in another language.

How did you create them, are they added with a plugin or they come from the theme?

June 7, 2019 at 2:12 pm #3976983

nenadM-4

It is plugin called Live Search and Custom Fields. The plugin is created that way

June 7, 2019 at 2:14 pm #3976987

nenadM-4

But is is only problem with them, because I have more string that have 2 different string and they are working fine.

June 7, 2019 at 3:11 pm #3977351

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

could you provide me with credentials so I can better check?
Also, could you give an example of a double string that works?

June 13, 2019 at 8:25 am #4010497

nenadM-4

[removed]

And the string that is working is chose

June 13, 2019 at 10:15 am #4011689

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I removed the credentials from your previous post because they were exposed in the public forum. Please don't add any private info unless we enable a private answer. As a further precaution, I'd suggest to change them.

In any case, they didn't work so can you please check?

June 13, 2019 at 11:48 am #4012459

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for the credentials. I did some tests but it's not clear how this plugin is working. I'd like to test it in a fresh install, so could you please install it here and explain how I can have a situation similar to the one on your site? hidden link

Please let me know when it's ready.

June 13, 2019 at 2:05 pm #4013503

nenadM-4

Ok I created filter on sample page

June 14, 2019 at 12:37 pm #4021503

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I can see the filter, but no"year" string, it's quite different from the one on your site. What I need to do to see them?

The topic ‘[Closed] String translating not working’ is closed to new replies.