This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Noman 1 month, 1 week ago.

Assigned support staff: Noman.

Author Posts
April 5, 2020 at 7:23 pm #5842825

marcoV-48

Hello,
with the translation of the texts on the homepage this works well except for the widgets. Then the texts do not change on the front end. I also updated everything again, also checked all the settings.

greetings
marco

April 7, 2020 at 7:20 am #5854357

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow the below steps and let me know how it goes?

1. Please make sure minimum requirements for WPML meet:
https://wpml.org/home/minimum-requirements/

2. Go to the WPML -> String Translation page and in the Auto register strings for translation section, enable the ‘Look for strings while pages are rendered’ option.

3. Re-visit the pages on the front-end where the string appears.

4. Re-visit the WPML -> String Translation page and search for that string.

5. Translate the string.

6. After translating the string, uncheck the auto-registration option.

7. If still an issue persists, Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Please let me know if this resolves your issue or if you need further assistance with this issue.

Thank you

April 7, 2020 at 5:52 pm #5860235

marcoV-48

Hello,
I have tried and checked everything but the problem remains, if I want to translate the text from the widget nothing changes on the front of my website, am I missing something?

Greetings Marco

April 8, 2020 at 9:12 am #5864195

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Debug info of your site seems fine. To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to deactivate and reactivate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

April 8, 2020 at 2:30 pm #5866763

marcoV-48

Hello
Unfortunately due to privacy reasons we cannot give access. Please tell me which steps I can take to solve this problem. Thanks
Greeting Marco

April 9, 2020 at 7:49 am #5872907

marcoV-48

hello,
I saw in the settings of the wp rest api controller setting some setting is disabled, can you tell me which setting should be enabled for the wpml to work properly?
greetings Marco

April 9, 2020 at 8:14 am #5873107

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Okay, could you please try below steps:

- Go to WPML >> String Translation.
- Click the link 'Translate texts in admin screens »' (you'll find it at the bottom of the page)
- You'll see a page with a large list of text strings. These are all the registered Admin options. Search for your widget and click on it’s name to expand its fields.

- If you find your required strings there, select it marking its checkbox and click the Apply button (bottom of the page)

- Once done you should see the string registered in WPML >> Strings Translation. Then you'll simply need to translate it and mark it as complete.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/translating-widgets/#registering-widget-fields-for-translation-via-string-translation

If still an issue persists you can display different widgets on different languages by following this method:
https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/

I hope it helps,

Thank you

April 9, 2020 at 8:48 am #5873719

marcoV-48

hello,
with the first option I saw no change of the text in the widget, I added the photo. After that I did the second option but when setting the Dutch language my widget is gone on my homepage?
greetings marco

April 9, 2020 at 9:05 am #5873905

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I saw the screenshot that you have attached and it looks like this issue is caused due to wrong language assigned to this string.

You can change some specific string default language to another language, please go to WPML >> String Translation and select required string checkboxes and select English language from ‘Change the language of selected strings’ dropdown as you can see in the attached screenshot.

If you want to change the language of a certain text domain, please go to WPML >> String Translation and click the "Languages of Domains" link ( screenshot attached). Here, you can select the domain and change the French language to English language.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/string-translation/#original-language-of-strings

Thank you

April 9, 2020 at 11:48 am #5875639

marcoV-48

Unfortunately this did not work, it is just that he does not want to change the translation in the widgets the rest of the normal text translations work. Could it still have to do with the setting rest api? I have attached a photo.

April 9, 2020 at 3:04 pm #5877277

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

In the screenshot you have provided it shows that WPML is not active, have you disabled WPML temporarily or there is something else?

1. Yes rest API should be enabled because many WordPress functions require that and WPML uses various WP functions to work properly.

2. It is important that you check this with default WP settings enabled and disable any special plugins or tools you are using to disable things in WP. So please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Twenty theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML & String Translation activated?

Without access to the site it is very difficult to figure it out further, may be you can create a copy of the site and remove all confidential data and just we will test it on a test page with a test widget where I can login and see what is causing the issue. But first lets try the above things I have mentioned. Thanks

April 16, 2020 at 6:29 am #5919161

marcoV-48

unfortunately the problem is not solved yet. I also saw the message that wpl would not be active, but still manage to translate texts except the widgets. can i see it somewhere where i can activate wpml? I also applied everything without result.

April 20, 2020 at 1:22 pm #5949591

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

1. Disable all plugins and switch to default theme then try activating WPML again. Please see attached screenshot to activate WPML. It should be enabled unless something is going very wrong in your site.

2. Also you should try to enable debug mode in your site. You can see how to enable it here:
https://wpml.org/documentation/support/debugging-wpml/
https://codex.wordpress.org/Debugging_in_WordPress

To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

3. If you don't see any result from the above steps. Then it could be that your site’s database is corrupted somehow and it's better to create a fresh WP installation and move all your content and plugins to the clean WP install. Here is a tutorial to help you with that:
hidden link

Thanks

The topic ‘[Closed] string translation’ is closed to new replies.