Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 8 voices.

Last updated by Minesh 4 years, 11 months ago.

Assigned support staff: Minesh.

Author Posts
September 12, 2014 at 8:56 am #469391

Nohemi

I am trying to: My admin language is french, i'm editing German post.

I visited this URL:

I expected to see: interface stay in french

Instead, I got: interface switch to German

Hi,

I have a strange problem with WPML string translation, the plugin switches admin language interface if i edit a post which use not my admin language.

I looked in source code (version 2.0.9.1) and i found in "icl_st_translate_admin_string" function:

	if ( is_admin() ) {
		$current_language = $sitepress->get_current_language();
		if ( $current_language == $sitepress_settings[ 'st' ][ 'strings_language' ] ) {
			return $option_value;
		} else {
			$sitepress->switch_lang( $current_language );
		}
	}

And switch_lang function switches admin language...

So when String translation do a translation in admin, it switches the language. This is normal behavior ?

I have read http://wpml.org/documentation/getting-started-guide/language-setup/setting-the-wordpress-administration-language/ and my configuration is correct. When i deactive the plugin, the problem disappears

Thank you

(Sorry for my bad english ^^')

September 12, 2014 at 12:01 pm #469600

Minesh
Supporter

Thank you for contacting WPML support!!

In order to investigate your issue, Can you please answer next questions:
=> Can you please share screen shot of WPML => Support Page
=> Can you please tell us what is your WordPress version?
=> Can you please tell us Which theme you are using? is it public?

September 12, 2014 at 12:51 pm #469648

Nohemi

It's WordPress 4.0 with 100% custom theme.

I've tried with twentyfourth, same result.

September 12, 2014 at 1:14 pm #469680

Minesh
Supporter

we have reported your issue to our development team and they are aware of it. They will work on this issue in order to fix it. We are planning to release new version very soon with fix available. Please be patient and we will keep you updated.

September 20, 2014 at 9:02 pm #476255

Hassan

I don't have anything new to add here, just want to confirm that someone else is also having this issue. WordPress 4.0 with latest versions of WPML and addons. I hope you release a fix asap. Thanks.

September 24, 2014 at 12:53 pm #478728

Rasmus

Having the same issue.

September 26, 2014 at 1:45 pm #480557

jonathanB-6

Same here

September 30, 2014 at 8:31 pm #483056

Michael

We're also having this issue with the Admin language not staying in the selected language. Any word on a fix?

October 11, 2014 at 2:58 pm #490424

jocelyne

I'm having the same issu over here as well...isn't there any fix yet???...it's been a month...

October 11, 2014 at 3:47 pm #490427

gabrielaB-2

To everyone here: please create a new thread with your issue. The more threads there are with one particular issue, the higher is the pressure on the development team to solve it!

February 4, 2015 at 11:25 am #554238

Minesh
Supporter

I am closing this ticket, Please make sure you are using latest WPML plugins.

Updating is simply the first step in troubleshooting issues. It is required because fixes are provided in the form of updates. You can

download latest WPML plugins from:
=> wpml.org => Account => Downloads

Please refer following link:
=> http://wpml.org/faq/install-wpml/

If it does not help please feel free to open a new ticket.

The topic ‘[Closed] String translation and admin language : unwanted switch’ is closed to new replies.