This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Lauren 1 year, 8 months ago.

Assigned support staff: Lauren.

Author Posts
September 25, 2018 at 4:27 pm #2764787


I am trying to: Assign content ans string translations to a translater.

Link to a page where the issue can be seen: Sorry, not online yet.

I expected to see: my client (translaters for one language) to translate content and strings, tick the box translation complete, see his "inbox" of translations empty or marked as completed.

Instead, I got: the translater seeing that in "String Translation", some jobs are still "waiting for a translator".

INFO: i understand you want an access to the website for testing purposes, but i cant give it here and now. I have to tick i have an issue, just to submit the ticket.

September 26, 2018 at 8:58 pm #2768751


Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Do you mean that after a string has been translated, it still shows as needing translation? Can you please send me a screenshot of where you are seeing this?

Also, Please try increasing the WP Memory Limit. Minimum requirements are 128Mb:

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

October 2, 2018 at 1:40 pm #2781664


Hi there Lauren.
Please find attached what my client is seeing. By clicking on translations he can write down the translation adequatly. Tick translation is complete. And the text still shows "waiting for translator".
I have added the code you sent me in order to increase the memory.
I have another big breaking issue, and will open another ticket for that.

October 2, 2018 at 2:39 pm #2781907


Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please go to WPML -> Translation Management and check to see if this string is sent to translation and waiting for a translator there. If so, try cancelling the job and then resaving the string in WPML -> String Translation.

If that doesn't resolve it, I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:


- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

If you are unable to allow me access, To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!