This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 5 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 13, 2019 at 4:34 pm

benN-11

I am trying to: translate my content at footer using String Translation

Link to a page where the issue can be seen: hidden link

I expected to see: the content of widget can translate to Chinese simplified, but it was not!

Instead, I got: the same as English content.

May 13, 2019 at 4:47 pm #3800763

benN-11

Hi,

Please help resolve the problem as this is the first time I use your plugin. Thanks.

Ben

May 13, 2019 at 7:33 pm #3801341

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I took a detailed look in your website and noticed your footer widgets content is not checked as 'translation complete' from your WordPress Dashboard > WPML > String Translation settings. Here is what you should try:

1 - In your WordPress Dashboard > WPML > String Translation click to choose the 'Widgets' text domain.

2 - Then make sure all the widget contents you have inserted in your footer are properly translated and you have checked the box 'translation complete' for every widget content. See: https://wpml.org/documentation/getting-started-guide/translating-widgets/

3 - As regarding the contact form you have inserted in the footer as the widget content, you also need to make sure the contact form is properly translated. See: https://wpml.org/documentation/plugins-compatibility/using-contact-form-7-with-wpml/

Please, let me know if you need any additional assistance and clarifications. Have a nice day.