This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 9, 2019 at 6:25 am #3773259

Tomislav Milenkovic

I am trying to: Translate content within the email

Link to a page where the issue can be seen: It can't be seen since I am trying to translate Woocommerce emails when someone makes an order.

For instance: I translated "Your UVI order has been completed!" as you can see here => hidden link as well as hidden link

Instead, I got: Things not being translated => hidden link

The wierd thing is that some translations work. As you can see in the e-mail I recieved the body of the email is in Slovene (hidden link).

May 9, 2019 at 6:46 am #3773365

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Could you please perform the below steps and share us the results, this will help us to narrow down the issue:

- Delete the string from string translation once and re-translate it

- Could you please change something in the settings for the title and see if it's updated properly on the string translation

Look forward to receiving your answers so we can get to the bottom of this issue.

Thanks

May 9, 2019 at 9:14 am #3774465

Tomislav Milenkovic

Hello.

I've followed the steps but i still have the same issue. What makes this even more interesting is the fact that woocommerce has few different mails (for when your order is placed, when it's finished, on-hold etc) and in some cases WPML translates the EMAIL tittle whereas in some cases it doesn't (picture 1). Same goes for main tittle wihtin the email (picture 2)

Picture 1:hidden link (1st email tittle not translated - 2nd email tittle translated)
Picture 2: hidden link

May 9, 2019 at 12:00 pm #3775911

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It looks like there are some settings missed which are creating this error, so, to debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

May 10, 2019 at 6:30 am #3781655

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you also specify when the email is not received as translated, it when you are processing the order, canceling the order, I just test with processing the order and it seems to be working fine?

Look forward to your reply.

Thanks

May 10, 2019 at 9:49 am #3782905

Tomislav Milenkovic

Hello.

Go to hidden link and add the product to card.

Procede to checkout BUT change language to SLOVENIAN.
After you do that insert details and make an order.

Choose " Neposredna bančna transakcija (TRR)" As a payment option. Once you complete the order I will mark it as complete and you will get an e-mail where you can see the problem.

Best regards,
Jure

May 10, 2019 at 11:50 am #3783857

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can replicate the issue, I am debugging the issue further and will respond to you soon.

In the meantime, could you also perform the below steps and share the results?

#1
Does disabling Kadence WooCommerce Email Designer sents the emails in the correct language.

#2
Can you confirm that you can experience same issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

Look forward to your reply.

Thanks

The topic ‘[Closed] String translation does not work with Kadence WooCommerce Email Designer’ is closed to new replies.