This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Admin Texts in String Translation are not updating when the default language option is updated.

Solution: String tracking can be fixed by following this steps:

  • Delete the strings already scanned into String Translation
  • Click the "Clear WPML Cache" button on WPML -> Support -> Troubleshooting
  • Re-scan the plugin for translatable texts using the "Theme and plugins localization" page

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/string-translation/ https://wpml.org/documentation/getting-started-guide/theme-localization/

This topic contains 2 replies, has 2 voices.

Last updated by nikolajW 3 weeks, 5 days ago.

Assigned support staff: Izzi Hassan.

Author Posts
September 25, 2019 at 4:00 am

nikolajW

Hello,

the String Translation doesn't update after making changes within 3.rd party plugin settings.
Please take a look at the screensot.
There you can see, that the strings are not updated.

How I can achieve that?

Regards

September 25, 2019 at 6:43 am #4636043

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Nikolaj,

Thank you for reaching out to us. I suggest deleting the strings that are not updating inside String Translation, then clearing your WPML cache and re-scanning the plugin texts.

To delete strings in String Translation:

  • Go to WPML -> String Translation
  • Filter for all the strings for that domain, as you have done in the screenshot
  • Check all the boxes next to the strings
  • Click the “Delete selected strings” button under the list

To clear WPML cache:

  • Go to WPML -> Support
  • Click on the link for the “troubleshooting” page underneath the list of WPML plugins
  • Click on the button called “Clear the cache in WPML”

To rescan the plugin:

  • Go to WPML -> Theme and plugins localization
  • Scroll down to the “Strings in the plugins” section
  • Check the box next to the plugin
  • Click the “Scan selected plugins for strings” button

Please try the process above and let us know if that resolves your issue.

September 25, 2019 at 12:34 pm #4638775

nikolajW

My issue is resolved now. Thank you!