This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I would like to export English string translations using the Import/Export feature in WPML -> String Translation.

However, English is not display as a target translation language.

Solution:
Please use this workaround.
Go to: /wp-content/plugins/wpml-string-translation/menu/string-translation.php
and remove this code:

if($al['code']==$string_settings['strings_language']) continue; 

This will enable export in any language.

0% of people find this useful.

This topic contains 5 replies, has 3 voices.

Last updated by thomas mang 2 years, 8 months ago.

Assigned support staff: Dat Hoang.

Author Posts
January 13, 2017 at 10:07 pm #1182064

Miguel

Hello!

Because I'm getting to much problems with string translation, I am trying to export all the strings to a .po file. My default language is Spanish (basque, english and french installed too).

I expected to see "basque, english and french" in the select form.

Instead, I got "basque, spanish and french"

Thanks a lot! 🙂

January 16, 2017 at 9:17 am #1182694

Dat Hoang

I think this is a missing feature of our plugin.

I'm reporting this to our 2nd tier supporters and our developers.

Will get back to you soon.

January 16, 2017 at 9:26 am #1182700

Dat Hoang

I reported it already.

Will let you know if we have any info.

January 18, 2017 at 9:47 am #1184692

Dat Hoang

Please go go to: /wp-content/plugins/wpml-string-translation/menu/string-translation.php
and remove this code:

if($al['code']==$string_settings['strings_language']) continue; 

This will enable export in any language.

Please try it and let's see that does help or not.

January 18, 2017 at 10:20 pm #1185425

Miguel

Hello!
It works perfect! Thanks a lot! 🙂

October 17, 2018 at 1:05 pm #2824664

thomas mang

this is still the case - for me this seems like a bug or i don't understand how to use it 😀
my use case: we've got a german site (default language) with english translations. i translated most of the strings on my local development environment. now i want to export the english translations (because german is the default language of the strings and already there) and import them on the production site. but i can't select "english" in the dropdown except i apply the workaround of yours. but even if i do that, i can't import the english strings on the production site - only the german ones are imported.
maybe i'm doing it wrong - what's the correct way to do that?