Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.36 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 34 replies, has 3 voices.

Last updated by Alejandro 1 month, 1 week ago.

Assigned support staff: Alejandro.

Author Posts
November 7, 2019 at 10:26 am #4904759

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

If the problem comes from the plugin WooCommerce add-ons premium try this.

Search for the strings that are not translated in WPML > String translation and then delete them.

Then, update the name of the add-ons and the strings will reappear, then proceed to translate them again.

Let me know if that works for you.

November 7, 2019 at 10:35 am #4904901

noamK-2

Hello Alejandro,

Please - Your reply is not clear at all!!!

1. "Search for the strings that are not translated in WPML > String translation and then delete them."

Which strings should be deleted? from what domain? All our addons strings are already translated properly!!

2. "Then, update the name of the add-ons and the strings will reappear, then proceed to translate them again."

Which names should we update? where? Not clear at all.

Thank you,

Noam Kroll

November 7, 2019 at 1:36 pm #4906255

noamK-2

Alejandro,

1. There are NO untranslated strings. The 3 problematic Addon strings are all translated properly, and none of them has a duplicate string, so there is actually nothing to delete!!!

See again the 3 problematic Addon strings on front-end: hidden link

2. Now, see these 3 string on the String Translations page. I searched for all strings that contain the words "country of residence". These words appear in each of the 3 problematic strings.

Results show that there are no duplicate or untranslated strings there.

See marked screenshot of the Strings Translation results page: hidden link

Noam Kroll

November 7, 2019 at 3:14 pm #4907423

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Sorry, i didn't express myself clearly enough.

When i said "Search for the strings that are not translated in WPML > String translation and then delete them." i mean the ones that are showing in English in the hebrew version of the page.

Let me rephrase this sentence: ""Then, update the name of the add-ons and the strings will reappear, then proceed to translate them again."

Go to products > Add-on > Edit > Change the name of the add-on (or change it slightly) and save it again. that should trigger a re-scan from WPML and will re-create the strings in WPML > String Translation.

Here's a small video where i explain what to do as well: hidden link

Regards.

November 19, 2019 at 1:48 pm #4972845

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,
We released a set of new updates that you can check in here: https://wpml.org/account/downloads/

They are all part of the WPML 4.3.4 Cycle so please update to that version and see if the problem disappears (this update focuses on String Translation related fixes but there are many other fixes as well).

Regards.

November 19, 2019 at 2:07 pm #4973069

noamK-2

Hello Alejandro,

Thank you so much for the update.

question please: If I update the WPML plugins to their recent version, how does it affect the issue of this ticket? Should I still do what you advised mew to do in your reply to this ticket NOVEMBER 7, 2019 AT 3:14 PM ?

Thank you,

Noam Kroll

November 19, 2019 at 2:51 pm #4973475

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I believe you will still need to do what i suggested in november 7th but i suggest you first update (since the update has a series of new "tests" that check the strings and try to avoid issues with them) and only then try my Nov. 7th suggestion.

Let me know how it goes.

November 19, 2019 at 3:12 pm #4973755

noamK-2

Hello Alejandro,

Thank you very much. Will do as you suggest and report back.

Best Regards,

Noam Kroll

November 19, 2019 at 3:49 pm #4974005

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Perfect,
Let me know how it goes!

November 29, 2019 at 10:14 am #5041519

noamK-2

Hello Alejandro,
Hope you are well.
Issue not resolved. Nothing seems to work.
Can you please look at it? hidden link
Thank you,
Noam Kroll

November 29, 2019 at 10:39 am #5041701

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Could you tell me what's the english name of the page?

Plus, i tried to access the site and it tells me there is an issue so i couldn't access. i tried to access via FTP so i could check what was the issue and it said the credentials were incorrect.

Would you mind doublechecking all that information and at most adding it over here, in the fields i just enabled for you?

Thanks in advance!

November 29, 2019 at 10:51 am #5041929

noamK-2

Hello Alejandro,

Good to see you.

First, we have just tried to update to the latest version of WPML, and the WooCommerce Multilingual plugin crashed our website. During the update, the "Activating" indication ran endlessly and activation could not be complete.

Here is the email error message :

Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugins, WooCommerce Multilingual.

First, visit your website (hidden link) and check for any visible issues. Next, visit the page where the error was caught (hidden link) and check for any visible issues.

Please contact your host for assistance with investigating this issue further.

If your site appears broken and you can't access your dashboard normally, WordPress now has a special "recovery mode". This lets you safely login to your dashboard and investigate further.

To keep your site safe, this link will expire in 1 day. Don't worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

When seeking help with this issue, you may be asked for some of the following information:
WordPress version 5.3
Current theme: Consulting Child Theme (version 1.1)
Current plugin: WooCommerce Multilingual (version 4.7.5)
PHP version 7.3.12

Error Details
=============
An error of type E_ERROR was caused in line 17 of the file /home/krollcon/public_html/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-emails.php. Error message: Uncaught TypeError: Argument 1 passed to WCML_Emails::__construct() must be an instance of WCML_WC_Strings, instance of woocommerce_wpml given, called in /home/krollcon/public_html/wp-content/plugins/yith-woocommerce-request-a-quote-premium/includes/emails/class.yith-ywraq-multilingual-email.php on line 42 and defined in /home/krollcon/public_html/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-emails.php:17
Stack trace:
#0 /home/krollcon/public_html/wp-content/plugins/yith-woocommerce-request-a-quote-premium/includes/emails/class.yith-ywraq-multilingual-email.php(42): WCML_Emails->__construct(Object(woocommerce_wpml), Object(SitePress), Object(WooCommerce), Object(wpdb))
#1 /home/krollcon/public_html/wp-content/plugins/yith-woocommerce-request-a-quote-premium/includes/emails/class.yith-ywraq-multilingual-email.php(74): YITH_YWRAQ_Multilingual_Email->__construct()
#2 /home/krollcon/public_html/wp-content/plugins/yith-woocommerce-request-a-quote-premium/includes/class.yith-request-quote-premium.php(

This has happened before, so WPML probably needs to fix it. We are now restoring we website from backup.

What do you think?

Can you please send an alert to your technical team? I will alert Amit as well.

Thank you,

Noam Kroll

November 29, 2019 at 10:57 am #5041991

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

That is not a general issue, it happens when there's something missing that maybe has a new function that is being called and since it doesn't exist, it ends up crashing the site, among so many other possible scenarios for it.

In this particular case it seems to have been an issue between "YITH woocommerce-request-a-quote-premium" and WooCommerce Multilingual.

It's happening in a class that it's receiving a parameter that is not correct.

However, please, check both the FTP and WordPress credentials to make sure they are ok and if needed add them in the fields i activated for your next answer.

Let me know when the backup has been restored and when i can access to the site and i'll gladly take a look at the problem.

Regards.

November 29, 2019 at 11:16 am #5042285

noamK-2

Hello Alejandro,

Thank you very much.

Talking to YITH support to see what they have to say.

Will let you know.

Thanks,

Noam Kroll

November 29, 2019 at 11:52 am #5042661

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Sure, let me know what they have to say and however we have constant contact with them, so if the issue is on their end they will probably do their best to fix it quickly, otherwise, we will do the same.

Regards.

The topic ‘[Closed] String translation failure’ is closed to new replies.