Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by thomasL-11 5 years ago.

Assigned support staff: Beda.

Author Posts
January 31, 2015 at 2:25 pm #552106

thomasL-11

I am trying to: do string translation from english to chinese (zh-hant) for admin_texts_theme_onetone for my "onetone" theme

I visited this URL: hidden link

I expected to see: I expected to see menu title "Home" (English) to translate to " 主頁" (Traditional Chinese) --- menu_title_0 is admin option variable name

Instead, I got: It doesnt translate to traditional chinese. It is still shown english.

January 31, 2015 at 2:27 pm #552108

thomasL-11

screen shot attached

February 1, 2015 at 4:04 pm #552328

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello Thomas

Thanks for the Debug infos.

Though, its missing his "plugins" part. I can't see what you have installed on your website.
Would it be possible to take a screenshot of your Dashboard > Plugins > Installed Page?

So I can see what you have there.

Would it maybe also be possible to enable the WPML Language Switcher n your websites footer? So I could switch languages and check them out.

I assume your WP Menu is either not transited in Dashboard > Appearance > Menu, or it isn't synchronized in WPML > Menu Sync.

Can you double check that?

Thank you

February 2, 2015 at 12:33 pm #552703

thomasL-11

plug-ins screen attached. I have also enabled the Language Switcher at my website footer.

BTW, There isnt any WP Menu with my site. I am using a theme "Onetone Pro" which I configure my menu over there. I have attached another 2 screens (one for my onetone pro setting and one for string translation screen) for your reference.

I believe as long as I can see the variable/name in String translation screen. It should work but it doesnt.

Thank you again for your prompt reply

February 2, 2015 at 4:03 pm #552956

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello Thomas

Now I know why your Plugins section was missing in the Debug infos 🙂

You have a outdated WPML Plugin running on your site there.
As you can see in Dashboard > Plugins there are updates available.

Please, would it be possible to follow as stated below:

1. Perform a full backup of your website and database
2. Update your Plugins

Once this is done, please try to translate the string again.
You may need to delete the particular string in WPML > String Translations, scan the theme and plugins again in WPML > Theme and Plugin localization, and then re-trasnalte the problematic string in WPML > String Translation.

Please can you let me know if this works?

Thank you

February 3, 2015 at 10:51 am #553445

thomasL-11

Hi Beda,

I upgraded the wpml and do the string translation again per your suggestion. It is still not working. I tried to translate the content for admin_texts_theme_onetone [onetone]section_content_0 and it is not working as well. Please help.

I have attached couple screen shot for your reference.

below I attached the latest debug information once again and hope it helps:

{"core":{"Wordpress":{"Multisite":"Yes","SiteURL":"http:\/\/www.kelletmobilitysolutions.com","HomeURL":"http:\/\/www.kelletmobilitysolutions.com","Version":"4.1","PermalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","PostTypes":"post, page, attachment, revision, nav_menu_item, myatu_bgm_gallery, tt_font_control, portfolio","PostSatus":"publish, future, draft, pending, private, trash, auto-draft, inherit"},"Server":{"jQueryVersion":"1.11.1","PHPVersion":"5.3.29","MySQLVersion":"5.1.73","ServerSoftware":"APACHE"},"PHP":{"MemoryLimit":"256M","UploadMax":"80M","PostMax":"80M","TimeLimit":"0","MaxInputVars":"1000"}},"plugins":{"active_plugins":[],"mu_plugins":[],"dropins":[]},"theme":{"Name":"Onetone Pro","ThemeURI":null,"Author":"\u003Ca href=\u0022http:\/\/www.mageewp.com\u0022\u003EMageeWP\u003C\/a\u003E","AuthorURI":null,"Template":"onetone-pro","Version":"1.5.3","TextDomain":null,"DomainPath":null},"extra-debug":{"WMPL":{"hide_upgrade_notice":"3.1.7","icl_capabilities_verified":true,"interview_translators":1,"existing_content_language_verified":1,"language_negotiation_type":"1","theme_localization_type":2,"icl_lso_header":0,"icl_lso_link_empty":0,"icl_lso_flags":0,"icl_lso_native_lang":1,"icl_lso_display_lang":0,"sync_page_ordering":1,"sync_page_parent":1,"sync_page_template":1,"sync_ping_status":1,"sync_comment_status":1,"sync_sticky_flag":1,"sync_private_flag":1,"sync_post_format":1,"sync_delete":0,"sync_delete_tax":0,"sync_post_taxonomies":1,"sync_post_date":0,"sync_taxonomy_parents":0,"translation_pickup_method":0,"notify_complete":1,"translated_document_status":1,"remote_management":0,"auto_adjust_ids":1,"alert_delay":0,"promote_wpml":0,"troubleshooting_options":{"http_communication":1},"automatic_redirect":0,"remember_language":24,"icl_lang_sel_type":"list","icl_lang_sel_stype":"classic","icl_lang_sel_orientation":"horizontal","icl_lang_sel_copy_parameters":"","icl_widget_title_show":0,"translated_document_page_url":"auto-generate","sync_comments_on_duplicates ":0,"seo":{"head_langs":1,"canonicalization_duplicates":1},"posts_slug_translation":{"on":0},"languages_order":["en ui-sortable-handle","zh-hant ui-sortable-handle","en ui-sortable-handle"],"urls":{"directory_for_default_language":0,"show_on_root":"","root_html_file_path":"","root_page":0,"hide_language_switchers":1},"admin_default_language":"_default_","ajx_health_checked":true,"setup_complete":1,"setup_wizard_step":4,"default_categories":{"zh-hant":"1","en":3,"zh-hans":2},"default_language":"en","st":{"sw":{"strings_language":"en"},"strings_per_page":"50","icl_st_auto_reg":"disable","strings_language":"en","translated-users":[],"theme_localization_domains":["onetone","woocommerce","woothemes","tgmpa","featured-gallery","onetone_framework","magee","options-framework","textdomain"]},"dont_show_help_admin_notice":true,"icl_lang_sel_config":{"font-current-normal":"#9A4806","font-current-hover":"#000000","background-current-normal":"#ffffff","background-current-hover":"#eeeeee","font-other-normal":"#E6E6E6","font-other-hover":"#9A4806","background-other-normal":"#ffffff","background-other-hover":"#eeeeee","border":"#fffff"},"icl_lang_sel_footer_config":{"font-current-normal":"#444444","font-current-hover":"#000000","background-current-normal":"#ffffff","background-current-hover":"#eeeeee","font-other-normal":"#444444","font-other-hover":"#000000","background-other-normal":"#ffffff","background-other-hover":"#eeeeee","background":"#ffffff","border":"#cdcdcd"},"icl_lang_sel_footer":1,"icl_post_availability":0,"icl_post_availability_position":"below","icl_post_availability_text":"This post is also available in: %s","icl_additional_css":"a.lang_sel_other{\r\nbackground: transparent !important;\r\n}","display_ls_in_menu":0,"menu_for_ls":0,"icl_language_switcher_sidebar":"0","language_selector_initialized":1,"theme_localization_load_textdomain":0,"gettext_theme_domain_name":"","translation-management":{"notification":{"new-job":1,"completed":1,"resigned":1,"dashboard":true,"purge-old":7},"custom_fields_translation":[],"doc_translation_method":0},"edit_languages_flag_migration":1,"just_reactivated":0,"custom_posts_sync_option":{"portfolio":1},"taxonomy_names_checked":true}}}

February 3, 2015 at 11:40 am #553490

thomasL-11

Hi Beda,

I guess I might have mess-up a little with wpml-config.xml. The key name wasnt match with the directory name. following is the content of my wmpl-config.xml:

<wpml-config>
<admin-texts>
<key name="onetone-pro">
<key name="section_title_0"/>
<key name="section_title_1"/>
<key name="section_title_2"/>
<key name="section_title_3"/>
<key name="section_title_4"/>
<key name="section_title_5"/>
<key name="menu_title_0"/>
<key name="menu_title_1"/>
<key name="menu_title_2"/>
<key name="menu_title_3"/>
<key name="menu_title_4"/>
<key name="menu_title_5"/>
<key name="section_background_0"/>
<key name="section_background_1"/>
<key name="section_background_2"/>
<key name="section_background_3"/>
<key name="section_background_4"/>
<key name="section_background_5"/>
<key name="section_background_video_0"/>
<key name="section_background_video_1"/>
<key name="section_background_video_2"/>
<key name="section_background_video_3"/>
<key name="section_background_video_4"/>
<key name="section_background_video_5"/>
<key name="section_css_class_0"/>
<key name="section_css_class_1"/>
<key name="section_css_class_2"/>
<key name="section_css_class_3"/>
<key name="section_css_class_4"/>
<key name="section_css_class_5"/>
<key name="section_content_0"/>
<key name="section_content_1"/>
<key name="section_content_2"/>
<key name="section_content_3"/>
<key name="section_content_4"/>
<key name="section_content_5"/>
<key name="menu_slug_0"/>
<key name="menu_slug_1"/>
<key name="menu_slug_2"/>
<key name="menu_slug_3"/>
<key name="menu_slug_4"/>
<key name="menu_slug_5"/>
</key>
</admin-texts>
</wpml-config>

I am seeing the attached screen under Translation management -> Multilingual Content setup. What am I supposed to do next?

thanks

February 3, 2015 at 11:46 am #553499

thomasL-11

and I am seeing following piece of code inside the theme:

for( $i = 0; $i < $section_num ;$i++){
	 
	 if( $section_1_content == 'slider' && $i == 0 ){
		 
		echo onetone_get_default_slider(); 
		 
		 }else{
 
 $section_title       = onetone_options_array( 'section_title_'.$i );
 $section_title_color = onetone_options_array( 'section_title_color_'.$i);
 $section_menu        = onetone_options_array( 'menu_title_'.$i );
 $section_background  = onetone_options_array( 'section_background_'.$i );
 $parallax_scrolling  = onetone_options_array( 'parallax_scrolling_'.$i );
 $section_css_class   = onetone_options_array( 'section_css_class_'.$i );
 $section_content     = onetone_options_array( 'section_content_'.$i );
 $background_size     = onetone_options_array( 'background_size_'.$i );
 $full_width          = onetone_options_array( 'full_width_'.$i );
 
 $mp4_video_url       = onetone_options_array( 'mp4_video_url' );
 $ogv_video_url       = onetone_options_array( 'ogv_video_url' );
 $webm_video_url      = onetone_options_array( 'webm_video_url' );
 $poster_url          = onetone_options_array( 'poster_url' );
 $video_loop          = onetone_options_array( 'video_loop' );
 $video_volume        = onetone_options_array( 'video_volume' );
 $video_volume        = $video_volume == "" ? 0.8 : $video_volume ;
 
  if(!isset($section_content) || $section_content=="") $section_content     = onetone_options_array( 'sction_content_'.$i );
 $section_slug        = onetone_options_array( 'menu_slug_'.$i );

 $background = onetone_get_background($section_background);
 $sanitize_title = "";
 if($section_menu  && $section_menu  != ""){
 $sanitize_title = sanitize_title($section_menu );
 if(trim($section_slug) !=""){
	 $sanitize_title = $section_slug; 
	 }
 }

I believe I might have to mess up a little with the above code in order to get translation working. Can you help?

February 3, 2015 at 3:58 pm #553731

thomasL-11

It is now working after changing wpml-config.xml as following:

 <admin-texts>
        <key name="onetone_pro">
            <key name="section_title_*" />
            <key name="menu_title_*" />
            <key name="section_content_*" />
        </key>
    </admin-texts>