Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Osama Mersal 5 months, 2 weeks ago.

Assigned support staff: Osama Mersal.

Author Posts
January 12, 2022 at 4:36 pm #10337847

jonatasG-2

String translation is not working on a part of my site

January 13, 2022 at 10:21 am #10342589

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I’ll be glad to help you today.

1) Could you please log in to this sandbox site and upload your theme? (hidden link)

After that, please create a test home page and replicate the issue. If the issue is replicable, please let me know the steps to reproduce it.

2) Could you please share your Debug information with me?
You can read a detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured.

Thanks for your cooperation

Regards,
Osama

January 14, 2022 at 4:52 pm #10354031

jonatasG-2

Hi,
I installed the theme and created a homepage to demonstrate the problem in translation. The strings "Inteligência Matemática" and "Frente à complexidade que caracteriza a gestão dos...." are not translating, all the other strings were translated normally, only these two do not work.

January 14, 2022 at 5:25 pm #10354071

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

1) Thanks for replicating the issue. I'll consult our 2nd tier supporters, and I'll update you as soon as I get their reply.

2) It's not related to the issue, but according to your Debug.info, the WP memory limit needs to be increased. PHP memory is fine, but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb. (Kindly check this page https://wpml.org/home/minimum-requirements/)

Add this to the top of wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Thanks for your cooperation and patience

Regards,
Osama

January 14, 2022 at 6:50 pm #10354453

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Could you please apply the workaround on this page? (https://wpml.org/errata/translating-an-array-of-options-misses-translating-the-first-element-in-the-array/)

I've applied it to the sandbox site, which fixed the issue.

Thanks,
Osama