This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When using Gutenberg, a new string is registered in String Translation for each block used. Solution: This is expected behavior, WPML extracts strings from page builders into a package in order to translate it. As you can see the package is named "gutenberg-16" for the page builder Gutenberg and the page id 16.

The user is translating manually and would like to disable this registration, but it is not supported. WPML still registers the strings in case the user changes the translation workflow in the future.

This topic contains 7 replies, has 2 voices.

Last updated by master 4 months, 2 weeks ago.

Assigned support staff: Jamal.

Author Posts
May 29, 2019 at 8:01 am #3912757

master

We don't understand why this behavior occurs. We are concerned that the database will grow a lot in the future.
Even if we disable the automatic search for strings, new blocks are still generating.
If we delete the string from an existing block, when we modify the block the string is generated again.

May 30, 2019 at 9:41 am #3921787

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

According to the debug information, you are using a plugin for Gutenberg blocks. Does the issue happen with these blocks or with default blocks?

Would you like to reproduce this issue in one of our clean installs? This way we can confirm it is a bug and I will escalate it immediately to our developers. If yes, please use the following URL to connect. Configure WPML similarly to your website and reproduce the error.
hidden link

If not reproduced, please allow me temporary access to your backend, and specify a page and a block I can test with to see the same thing as you, any screenshots or screencast will help.

You may also run a compatibility check, by switching to a default theme (Twenty seventeen) and deactivating all plugins except WPML plugins, and test again, if the issue is not reproduced, it means, it is a conflict with your theme or another plugin, reactivate the theme and plugins 1-by-1 and check each time to detect which one causes the conflict.

Looking forward to your reply.

Best regards,
Jamal
WPML Support

May 30, 2019 at 10:23 am #3922047

master

Hi Jamal,
thank you for your answer.
I reproduced the issue in the sandbox doing this:

  • Switch wordpress installation to spanish.
  • Activate English and Catalan languages.
  • Activate string translation and translation management.
  • Install and activate "Advanced custom fields pro"
  • Make "ACF fields" translatable
  • Add new field on pages

    Then, I write 3 new paragraph text on a new page and duplicate that page to catalan and english.

    Now this 3 blocks appear as a string:

    hidden link

May 30, 2019 at 1:16 pm #3923129

master

Hi Jamal,
I made another test on a clean installation without plugins (only WPML) and less steps with same results:
Install WordPress with spanish language.
Install an activate wpml, string translation and translation management
Activate English and Catalan languages.
Ad new page with 3 new paragraph blocks
Every block become a string.

May 30, 2019 at 2:29 pm #3923763

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your efforts. I approached our 2nd Tier team about this, and they confirm that it is expected behavior. WPML extracts strings from page builders into a package in order to translate it. As you can see the package is named "gutenberg-16" for the page builder Gutenberg and the page id 16.

I hope this removes your concern about database size. Let me know if you have any questions.

Best regards,
Jamal

May 30, 2019 at 2:44 pm #3923963

master

Hi Jamir,
Yes, we are aware that every page is creating a string domain like "guttenberg-[page-id]" with all the strings and we are still concern about database size, because is growing with every page.
Please add an option for disabling this automatic string generator because we are using manual translation for content.
We tried to uncheck al gutenberg domains in "automatic string search" but blocks are still adding as a strings.

May 30, 2019 at 3:16 pm #3924157

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

I understand your concern, especially as you are using manual translation. We register string packages in manual translation just in case the user would like to change to translation editors.

Our upcoming version of WPML will be focused on strings performance, we may have an option to disable this behavior. I suggest you ask a feature on the following page
https://wpml.org/suggest-a-new-feature-for-wpml/

Best regards,
Jamal

May 31, 2019 at 6:01 am #3927925

master

Thank you Jamal,
I'll ask for this feature on that page.