Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 2 voices.

Last updated by Radu 1 year, 10 months ago.

Assigned support staff: Radu.

Author Posts
October 26, 2019 at 1:28 am #4830475

nikolajW

By the way, why WPML is sometimes switching to the English language by itself?
If you do the testing please keep this in mind.
Stay alway in german language to see this behaviour happening.

October 29, 2019 at 11:48 am #4847107

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nikolaj,

I created a new order on my website by going to WooCommerce → Bestellungen → Bestellung hinzufügen.
I copied all the field values from your order here hidden link, and pressed the Erstellen button. However, no pending action was created.

Do you use different steps to create the order on the sandbox website, please? Or maybe there's something else I should do? Once I'll be able to replicate this, I'm sure I'm gonna be able to find out why the translated strings are not working. I just need to be able to replicate it first.

Thanks,
Radu

October 30, 2019 at 11:21 am #4854925

nikolajW

It is important to differentiate between an Order and Subscription.
Creating an order for a subscription product can be limitless or limited by one order per any status of the subscription.

Because the subscription product is already active, you will only see one pending action that may be run manually.

November 5, 2019 at 1:23 pm #4889441

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nikolaj,

Thank you for clearing things out between the order and subscription. I created a new subscription and now I can see the renewal action. I can see that I can create it again every time I change the status of the subscription from active to pending, and then back to active.

I checked this out in the last few days, trying to check the translation of the mail text. However, I lately found that the subscriptions plugin was in a staging state on my local website and, according to this article https://docs.woocommerce.com/document/subscriptions-handles-staging-sites/, the mails are not send in this case.

Now I'm creating a new website to get rid of the staging status and have a look at the mail messages. Now that I can create the same action, I'm gonna check things out and look for a fix. I just wanted to give you a status update on this (to let you know that I didn't forget about this ticket), and I'll keep you posted about the progress I'm making on this.

Thanks,
Radu

November 5, 2019 at 3:26 pm #4890833

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nikolaj,

As I said in my previous message, I made this ticket a priority lately to make some progress on it. I was able to finally replicate this mail and make it appear on my side. Basically, these are the steps I need to take in order to get that mail:

  • go to the subscription;
  • mark it as on hold;
  • update the subscription;
  • mark it as active;
  • update the subscription;
  • go to Settings → Actions → Pending;
  • run the action;
  • go to WooCommerce → Order;
  • edit the latest order;
  • set its status as complete.

Once I did all of this, I was able to receive the email from first screenshot (from the attached images). The settings I used are captured on the other two screenshots.

Can you make sure that you're using the same settings and check again the mail you receive, please?

Thanks,
Radu

screenshot3.png
screenshot2.png
screenshot1.png
November 13, 2019 at 2:48 am #4935477

nikolajW

Hey,

I'm a bit confused.
In "screenshot2.png" you have English text.
The translation from "screenshot3.png" is ok.
But on my system the base language is English.
I guess this doesn't matter?

I don't need to do these steps, because it happens already on regular steps.

But you could reproduce it, so it is something that should be fixed.

If I run the schedule on my system, no matter which language I had when I bought the product or have set in backend, the mail is always the same.
Also, the generated PDF is mixed up with German and English versions.

Anmerkung 2019-11-13 105021.jpg
Anmerkung 2019-11-13 104042.jpg
November 21, 2019 at 12:59 pm #4988185

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nikolaj,

The strings that you set in Dashboard → WooCommerce → Settings → Email need to be in the same language as your website default language. As I can see, your website default language is German. In this case, you should add the text in German in WooCommerce mail settings, and then add the translation in WPML → String Translation.

I'm my previous screenshots I wanted to show you that I added the string in the email settings (You are doing it right!), then add the translation for it (in String translation). Once I did that and run again the scheduled action, the translation appeared in the mail (Sie machen es Richtig! - test).

Can you tell me once again which mail from WooCommerce → Settings → Email (hidden link) are you trying to translate, please? This way I can test it once again on my website and see if I see any issue.

Thanks,
Radu

November 21, 2019 at 8:13 pm #4992909

nikolajW

Hey,

on the screenshot, you may see, that it is set in german.
But somehow in other mail settings, the language is sometimes in English.
I did translate those text but it turns back to English by itself.

And I noticed that WMPL has a dropdown menu under the text-fields.
But those options aren't in the "New Renewal Order" mail setting.
Why is that?

Regards

Anmerkung 2019-11-21 211051.jpg
Anmerkung 2019-11-21 211011.jpg
December 2, 2019 at 5:56 am #5050725

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nikolaj,

I tested this mail a few more times on my side to see if I can replicate the issue but everything still worked well. The dropdown are usually appearing on the mails added by the main WooCommerce plugin. I think that these are missing on the mails added by the Subscriptions plugin.

The values that you add to the mails from the Subscription plugin are set to be from the default language set on WPML.

As for the mails, can you check this one more time but first look at Dashboard → Users, edit your account, and check the value set for the Language field. Since you are creating the subscriptions using your account, that's the language used for the mail. Just try to set the value for this field to English and German and see what is the language of the mail on each situation.

Also, I checked the staging website and I could see that almost all the plugins are deactivated, including Duplicator. Can I activate it so I can grab another package and check it one more time on my computer? I just wanted to make sure that there's no problem if I activate it.

Thanks,
Radu

December 2, 2019 at 1:05 pm #5053467

nikolajW

It is good to know that the site language shows the base or translated text.
Somehow this MUST be communicated to the webmaster otherwise it will be not obvious.
I couldn't understand it at all until now! :/
From my view, the base text must be shown, because the webmaster did enter it.
In the settings, the visibility option for this behavior might be a good thing.

But thank you very much to make me aware of it! 🙂

December 2, 2019 at 1:10 pm #5053503

nikolajW

Sadly I can't test it, because there is an issue with subscriptions.
Can't run the schedule...
I need to fix this first.

But I don't understand, why the backend site language is important for the purchase?
It should be the language that has been set with WPML or am I misunderstanding something?

Regards

December 3, 2019 at 3:49 pm #5062567

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nikolaj,

The language of the backend is not the one important for the purchase. The language set for the user is important. When you have an account created on the website, there's a language set for it. When placing an order, your account is associated with that order (because you used that account to place the order).

WPML is made to send the email in the language of the account that was used to place the order. If your account has set to have the Spanish language, for example, there's no point in receiving an email in English.

I tried to make a quick simple explanation about how things work and I hope this makes sense. If you have any idea about how this should work instead, please share it with me. Only this way we can improve our products for you.

Thanks,
Radu

The topic ‘[Closed] String translation isn't proper displayed’ is closed to new replies.