Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Sumit 4 years, 2 months ago.

Assigned support staff: Sumit.

Author Posts
May 17, 2017 at 10:20 am #1278018

attiahA

Hello

i face a many problems with WPML

the user menu in English take the Arabic translation
and some translation in Arabic when the page load shown fine and after the page completely load the strings changed to the other language English something crazy

i record this video
hidden link

i try to deactivate all plugins one by one and the problem not solved .
i confirm the problems comes from the WPML or any setting modified by WPML Support in my website

May 17, 2017 at 1:32 pm #1278254

attiahA

i can get any replay ???????????????

May 17, 2017 at 3:32 pm #1278367

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for opening a new thread!

#1 Can you please go to WPML > Languages > Language filtering for AJAX operations : and make sure you have checked "Store a language cookie to support language filtering for AJAX"?
#2 I can not see a submenu of payment parent menu. Can you please explain me how can I see this menu?

Thanks

May 17, 2017 at 5:29 pm #1278474

attiahA

Hello
WPML > Languages > Language filtering for AJAX operations not checked and after i check it no any changes in our problem

the sub menu sure for users you can register a user or open the private replay and i will give you the access information to see all the problems with your self directly and to decrease the time for replays from me and you

May 18, 2017 at 6:46 am #1278783

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Instructions to send private information are here: hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thanks

May 18, 2017 at 1:51 pm #1279294

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

#1 Menu issue: I am still not seeing the menu you have shown in the video! When I hover on payment button nothing happens. Please let me know the steps to see this menu!
I am attaching the screenshot for the same.

#2 About "CONTINUE COURSE" string: You haven't translated this string yet. Please go to String Translation and find the string "CONTINUE %s COURSE" then translate this. Please don't remove %s from translation.

#3 About course strings issue: - I am seeing a javascript error from BuddyPress. The localization script is 404. In source code, I am seeing the wrong URL of js file

<script type='text/javascript' src='<em><u>hidden link</u></em>' defer '>

The file path is not correct. And this transaltion is not coming from WPML. It is from MO files.
Are you using some kind of defer javascript parsing method? It is causing an issue with the above js file.

Thanks

18-05-2017 07-13-02 PM.png
May 18, 2017 at 2:11 pm #1279322

attiahA

#1 Menu issue: for the menu hover over or click in username i mark it in the attached image

#2 About "CONTINUE COURSE" i translate the string as you say and the problem solved

#3 About course strings issue: i use an code to defer javascript in my functions.php

add_filter( 'clean_url', 'defer_parsing_of_js', 11, 1 );
function defer_parsing_of_js ( $url ) {
if ( FALSE === strpos( $url, '.js' ) ) return $url;
if ( strpos( $url, 'jquery.js' ) ) return $url;
return "$url' defer ";
}

when i remove it this problem solved but i want to defer javascript how we can do this in safe method

1279294-18_05_2017_07_13_02_PM.png
May 19, 2017 at 8:39 am #1279883

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Okay! Now I can see the issue! Looks like the strings you have translated in String Translation are not correct and it is coming from plugin settings.
I need to debug this issue locally I am unable to check it on your site!
For this, I'll need to temporarily install a plugin called "Duplicator" on your site. This will allow me to create a copy of your site and your content.
Once the problem is resolved I will delete the local site.
Please let me know if it is okay?

About defer javascript issue: This code is not correct! You can not add defer attribute in URL it needs to be added as a tag.
Currently, scripts tag looks like

<script type='text/javascript' src='<em><u>hidden link</u></em>' defer '></script>

But it should be like

<script type='text/javascript' src='<em><u>hidden link</u></em>' defer='defer'></script>

There are many free plugins! You can install and tests.
OR you can also contact one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors/

You will get the custom assistance you need to get on with your project.

Before doing so please have a look also here: http://wpml.org/documentation/support/wpml-contractors/guidelines-for-people-looking-for-consulting-help/

Thanks

May 19, 2017 at 9:50 am #1279944

attiahA

Ok you can do it
Duplicator installed in my website

Just small hint
My website url and all url redirect to
hidden link

May 19, 2017 at 3:08 pm #1280360

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am sorry it took me a little long time because I was thinking that it is core theme issue as you said you have checked by disabling each plugin.
But the issue is coming from "Vibe Custom Types" plugin.

This is not a WPML issue instead results of using wrong WPML API.
The theme is translating these links using WordPress localization functions in this file \themes\wplms\templates\login\full_login.php line number 20

There is a filter called "wplms_logged_in_top_menu".
"Vibe Custom Types" using this filter and translating again those values that are already translated.
\plugins\vibe-customtypes\includes\loggedin_menu.php line number 27

Please let the theme support know about it.

Meanwhile, as a workaround, you can go to \wp-content\themes\wplms\templates\login\full_login.php line number 60 and comment out this line.
How to comment out:-
Replace this code

$loggedin_menu = apply_filters('wplms_logged_in_top_menu',$loggedin_menu);

with

//$loggedin_menu = apply_filters('wplms_logged_in_top_menu',$loggedin_menu);

NOTE: Please make a complete backup of site files and database before you proceed (Just a good practice!)

Thanks

May 19, 2017 at 5:54 pm #1280528

attiahA

Thanks i have open a support topic in the theme support forums and waiting theme support replay

hidden link

May 22, 2017 at 9:28 am #1281351

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am sorry I can not see the replies on their forum! It is visible only for logged-in users.
Meanwhile, did you try the workaround? Does it work for you?

Thanks